9

I have Xubuntu 17.04, and I was wondering if there was a way to actually downgrade from 17.04 to 16.04, for a couple of reasons:

  1. Because mGBA fails to work in 17.04
  2. Because Parole Media Player freezes when I rewind
  3. Because LMMS closes when I try to load the sample songs
  4. etc.

Question:

Is there any way to downgrade from Xubuntu 17.04 to 16.10?

  • 7
    I think you should investigate these issues rather than just bin the whole thing – cat Sep 3 '17 at 0:36
  • 2
    These sound like they could be related issues with the audio setup on your system. I think you'd be better served by investigating that possibility. All of these apps have to use the audio system. – StephenG Sep 3 '17 at 8:23
  • @StephenG I think you may have right. However, I never found any major problem with my audio drivers on any Linuxes, despite that I use the notorisouly single-threaded mplayer for video play. But the Internet is somehow full with blocking problems caused by audio driver problems, I simply can't really understand this. – user259412 Sep 3 '17 at 17:29
  • @peterh Indeed. The last audio issue I had was trying to get Windoze to use the audio system my dual-boot Linux Mint 18 picked up and ran with without problems. Didn't see any Xubuntu 17.04 sound issues in a quick web search. – StephenG Sep 3 '17 at 17:37
  • It won't help you now, but I've been burned by upgrades multiple times. Now, with big hard drives, I just copy my whole root and separate home partitions to new, empty partitions and do the upgrade there. This leaves the working system ... working. Once the upgrade is successful in the other partitions, I just tell grub that they are the default system to boot. All you have to do is edit /etc/fstab in the new copy to reflect the UUIDs of the test partitions. To make this easier, I put most of my other data like media files in another partition unaffected by all of this. gparted is your friend! – Joe Sep 9 '17 at 10:42
13

There is no officially supported way to do that, however you can do it.

The downgrade will probably result in more serious problems than the upgrade caused. The reasons:

  1. The package install/removal scripts weren't tested for downgrade.
  2. There could be package-specific configuration files, databases, whose format changed with a new version. In these cases, their format upgrade were developed, but their downgrade mostly weren't.
  3. The package dependencies aren't very tested in downgrade scenarios. It results, during the downgrade, some state of a system can appear in which incompatible packages are there coincidentally.

All of these problems are rare. But a typical Linux system has thousands of packages, so at least in one of them, you will surely confront problems. These you will have to fix by hand, individually.

The exact steps for a dist-downgrade are detailed in this answer.

(Not topic of the question, but it is very funny: on the same way, you can also switch between different Debian-based distributions, maybe even without a reboot. If there is multi-architecture support in both of them, you can even switch architectures without a reboot.)

Because your goal is to avoid some, similar, rare package-specific problems after an upgrade, you would likely avoid the ones what a dist-downgrade would cause.

Thus, I would suggest more a workaround solution:

Downgrade only the few packages with which you have a problem.

It is very simple:

  1. Temporarily add also the package sources of your old distribution into the /etc/apt/sources.list. Thus, your sources.list will - temporarily - contain the package sources for your both distribution version.
  2. Run an apt-get update to load the caches.
  3. An apt-cache show mybuggytool will then show your mybuggytool in all available versions, in both repositories. For example, you will see mybuggytool in versions 1.1-crap and in 1.3-crap.
  4. Choose the more sympathetic one, which will be likely 1.1-crap.
  5. Install it with an apt-get install mybuggytool=1.1-crap
  6. Remove (or comment out) the lines of your old disto from the sources.list, and then apt-get update again.

In this way, you will have the package of the buggy tool - but, from your old distribution. As the overwhelming majority of the libraries are developed to be backward compatible, you will face a problem with a much lower probability.

You may want to make exempt these packages from the future upgrades. It is detailed in this answer. The important part is:

  • You can hold a package by the command apt-mark hold mybuggytool.
  • You can unhold it by apt-mark unhold mybuggytool.
  • Thanks @peterh! This is just what I needed! Thanks a bunch!! – JBoy Advance Sep 2 '17 at 21:09
  • @JBoyAdvance My pleasure :-) – user259412 Sep 2 '17 at 21:25
  • 1
    Lovely, very complete answer. – Joe Sep 9 '17 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.