0

I am pretty new to the Linux environment. I have installed Mint 18.1, which is mostly used as HTPC (to watch movies on TV connected with HDMI cable). Everything works fine, except that it does not play sound on certain video files. When I checked these files one-by-one, I found that all problematic ones have Codec: MPEG Audio layer 3 (mp3) and Sample rate 44100 Hz, while if the file has 48000 Hz (same codec), it plays fine. The video is fine for both.

The player I use mostly is Kodi, but the same happens when I use default Media player which came with Mint (IIRC Xplayer?).

Audio: Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0

Motherboard: ASRock H77M ----> with Realtek ALC892 audio.

Where is the problem? Is it driver? Is it codec? Is it just settings?

6
  • What video player(s) are you using? Sep 2, 2017 at 11:18
  • The player I use mostly is Kodi, but the same happens when I use default Media player which came with Mint (IIRC Xplayer?).
    – Monardo
    Sep 2, 2017 at 11:43
  • Try a few other players. E.g. vlc and mpv. Do you get the same results with those? Sep 2, 2017 at 11:49
  • mpv does the same... vlc does the same too, but then I started playing with "Audio>Audio Device" and among many choices which none worked "hda intel pch hdmi direct sample mixing device" had sound. What does that mean?
    – Monardo
    Sep 2, 2017 at 23:59
  • Does "Audio>Audio Device" have many settings for you? I don't know much about sound, but I would first make sure that you are actually using your Intel sound card, seeing as you appear to have an onboard sound card. Sep 3, 2017 at 0:10

1 Answer 1

0

I found the solution:

Most probably the reason was that my AVR was not accepting 44100 Hz.

In "/etc/pulse/daemon.conf" I uncommented the line ; default-sample-rate = 44100 and changed to 48000.

Restarted and voila...

Thanks for help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .