3

N.b. Since this is an issue on a machine running "Ubuntu +1 (alpha)", it's out-of-bounds on AskUbuntu, so I'm hoping for some help here.

I encountered some odd screen behaviour this morning. I have been using Ubuntu Gnome 17.10 (alpha2) for a couple weeks now quite happily, with primary monitor on the right, and secondary on the left with spanned wallpaper -- all correctly displayed, and mouse correctly travelling from the far left edge of the secondary monitor, across the middle divide, to the far right edge of the primary monitor.

But this morning this behaviour has changed:

  • the primary/secondary monitors are correctly identified;
  • and the panels appear only on primary (as is correct in my setup);
  • but the wallpaper is reversed, and the top left of the right (primary monitor) seems to be "0,0", so the mouse travel from the far right of the primary monitor, then appears on the far left of the left monitor (and the centre seam is a hard boundary).

xrandr reports:

Screen 0: minimum 320 x 200, current 3600 x 1200, maximum 8192 x 8192
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 connected 1680x1050+1920+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050     59.95*+
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
   720x400       70.08  
DP-3 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1200     59.95*+
   1920x1080     60.00  
   1600x1200     60.00  
   1680x1050     59.95  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  

And ~/.config/monitor.xml appears to be correct (so far as I understand it):

<monitors version="2">
  <configuration>
    <logicalmonitor>
      <x>1680</x>
      <y>0</y>
      <scale>1</scale>
      <primary>yes</primary>
      <monitor>
        <monitorspec>
          <connector>DP-3</connector>
          <vendor>HWP</vendor>
          <product>HP LA2405x</product>
          <serial>CN43220DJ0</serial>
        </monitorspec>
        <mode>
          <width>1920</width>
          <height>1200</height>
          <rate>59.950672149658203</rate>
        </mode>
      </monitor>
    </logicalmonitor>
    <logicalmonitor>
      <x>0</x>
      <y>0</y>
      <scale>1</scale>
      <monitor>
        <monitorspec>
          <connector>HDMI-2</connector>
          <vendor>DEL</vendor>
          <product>DELL 2209WA</product>
          <serial>H735H9862DNL</serial>
        </monitorspec>
        <mode>
          <width>1680</width>
          <height>1050</height>
          <rate>59.954746246337891</rate>
        </mode>
      </monitor>
    </logicalmonitor>
  </configuration>
</monitors>

And if I remove monitors.xml, the Display Settings dialog does not create a new one.

However, there is a discrepancy here: while monitors.xml correctly puts the Dell (secondary, physically on the left) at "0,0", the output of xrandr shows what I actually see, that the HP (primary, physically on the right) has the "0,0", and the Dell to the left of it is offset by 1920 (i.e. they are "virtually" reversed).

So "Display Settings" sees them incorrectly, i.e., as [#1][#2] although they ought to appear as [#2][#1]. This is what happens when I try to save the correct Display Settings with "Arrange Combined Displays":

settings-dialog

The setting simply doesn't "stick", and "Primary" always reverts to the left, instead of staying on the right.

Shutter sees my monitors/desktop as the Display Settings combined displays depicts it:

combined-displays

But this is what I actually see:

monitor-photo

How can I persuade Gnome Ubuntu to recognize that my desktop 0x, 0y should be the upper left of the secondary monitor, not the primary?

  • 1
    I have similar symptoms, haven't tested shutter though. There is an issue posted on launchpad that touches this as well. bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/… – kmpm Sep 5 '17 at 8:06
  • 1
    Thanks for the bug link. I see that since your comment was posted, another bug has been linked as related: bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/… So there is hope of a fix soon, anyway! – Dɑvïd Sep 5 '17 at 10:02
  • I'm flagging this question since it is a bug with an Ubuntu beta that will be fixed before release. – Jeremy Bicha Sep 8 '17 at 1:51
  • 1
    Nope not fixed, still problematic in production release of 17.10... – Christof Kälin Oct 19 '17 at 20:06
  • @ChristofKälin That's odd - it has been fixed for me for some weeks now. Have you run all the post-upgrade updates? (Although why this wouldn't be in the release itself is a puzzle.) – Dɑvïd Oct 20 '17 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.