3

Lynx can start with the option -noredir which allow us to visit web-pages without (possible) redirection to another page. I searched enough and did not find a similar option for other browsers , such as firefox,chrome,midori,seamonkey,epiphany and opera. Even the add on's in firefox (and extensions for chrome) does not solve the problem of redirection. I am wondering, why such a simple property is not properly implemented in the well known browsers. My question is if you know some browser that supports such a property.

5
  • I once had a firefox extension, which would only display a notification bar for a redirect and follow it when you click it. Not sure how it was called, but there must be more extensions like this.
    – allo
    Commented Sep 1, 2017 at 14:33
  • I remember http://domain requests were automatically redirected to http://domain/ by apache. Is it still true?
    – Emmanuel
    Commented Sep 1, 2017 at 14:33
  • @allo I've tried all the similar extensions. Nothing worked for me. I wrote that for some older versions of firefox there was an extension noredir which, as far as I read it was working fine. But, this extension is not compatible with the newer versions of firefox.
    – 111
    Commented Sep 1, 2017 at 14:35
  • 1
    The old Opera (i.e. before becoming a Chrome skin) had an option for that, but IIRC you had to enable it in opera:config. Commented Sep 1, 2017 at 14:36
  • @Emmanuel maybe, I am not sure.
    – 111
    Commented Sep 1, 2017 at 14:37

1 Answer 1

0

This article may be of some interest to you. Such options exist in both Firefox and Chrome, but they're not easy to find. I think Edge and Safari might have an option to do this, but I'm not sure. Opera should have an option similar to Chrome's.

Depending on the site, you may also be able to stop redirects by disabling JavaScript (there are numerous extensions for both Chrome and Firefox that allow you to do this on a per-site basis).

3
  • yes I've seen this article. Most of them are outdated at least in firefox and chrome.
    – 111
    Commented Sep 1, 2017 at 18:44
  • I'd be willing to bet the setting still exists in Firefox, but you have to go through about:config to enable it. Commented Sep 1, 2017 at 18:55
  • hmm, I tried to change network.http.redirection-limit from 20 to 0. I got the error The page isn't redirecting properly. It seems that controls the redirections but instead of loading the webpage which corresponds to the address I wrote, it stops loading the page providing an error.
    – 111
    Commented Sep 1, 2017 at 20:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .