1

I have found this: http://xpo6.com/skype-for-linux-behind-a-proxy-server/ changed the ip address and the port, but it still does not work. Then I tried

> export http_proxy='http://username:password@ip_address:port_number/' &&'

which is what I use in my

> /etc/apt/apt.conf

To be able to use aptitude/apt-get under the proxy. Still no luck. Any hints on how to change the script? The script from the above link is:

> #!/bin/bash
SCRIPT=$(readlink -f "$0")
USR_DIRECTORY=$(readlink -f $(dirname $SCRIPT)/..)
SKYPE_PATH="$USR_DIRECTORY/share/skypeforlinux/skypeforlinux"
SKYPE_LOGS="$HOME/.config/skypeforlinux/logs"
mkdir -p $SKYPE_LOGS
export http_proxy='proxy.server:8888' &&
export https_proxy='proxy.server:8888' &&
nohup "$SKYPE_PATH" --executed-from="$(pwd)" --pid=$$ "$@" > "$SK

YPE_LOGS/skype-startup.log" 2>&1 &

I have the same problem with programs like MegaSync, Dropbox, Anki.

  • Have you tried: export http_proxy='http://proxy.server:8888'? Without && at the end and http:// and the beginning of proxy server name ? – mrc02_kr Sep 1 '17 at 12:56
  • @mrc02_kr I don't understand the part after "at the end". – wondering Sep 1 '17 at 13:07
  • You have now: export http_proxy='proxy.server:8888' &&. Change it to: export http_proxy='http://proxy.server:8888' – mrc02_kr Sep 1 '17 at 13:08
  • @mrc02_kr I assume the same applies to the https line. Anyway, it did not help. – wondering Sep 1 '17 at 13:13
  • How about the other variables, can something be wrong elsewhere? I did not play with the rest of the code. – wondering Sep 1 '17 at 13:15
1

http_proxy and https_proxy are the standard settings for configuring HTTP proxies for applications. They work for APT because it uses HTTP (by default) to download packages and package information. They won't work though for many other network applications because most stuff does not use HTTP. From a practical perspective, you're likely going to have to use a SOCKS proxy (SOCKS is a more generic protocol designed specifically for proxying outbound network traffic), or a VPN with a remote router. For the first case, you would need to set socks_proxy will work for some things that support SOCKS natively, but you'll need other tools to handle the second (there's a command called socksify that you can use to wrap applications without native SOCKS support). For the second case, you shouldn't have to do anything locally, but unlike with SOCKS, you probably won't be able to find a free VPN setup with a remote router (though there are multiple paid options at leas tin the US).

  • So I would just have to try to use 'socks_proxy' in the above script? How do I do that? – wondering Sep 1 '17 at 16:43
  • The same way you're exporting the http_proxy variable. Keep in mind though that you need an actual proxy to point this at, and most open proxies do not support SOCKS. – Austin Hemmelgarn Sep 1 '17 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.