1

Unable to share NFS to clients. Throwing error when i execute showmount -a on the NFS server.

/root # showmount -a
clnt_create: RPC: Port mapper failure - Unable to receive: errno 111 (Connection refused)

/root # rpcinfo -p
No remote programs registered.

/root # ps -ef | grep notify
rpcuser   4467     1  0 Aug29 ?        00:00:00 rpc.statd --no-notify
rpcuser   4477     1  0 Aug30 ?        00:00:00 rpc.statd --no-notify
rpcuser   4509     1  0 Aug30 ?        00:00:00 rpc.statd --no-notify
rpcuser   4516     1  0 03:14 ?        00:00:00 rpc.statd --no-notify
rpcuser   4650     1  0 Aug29 ?        00:00:00 rpc.statd --no-notify
rpcuser   4677     1  0 Aug30 ?        00:00:00 rpc.statd --no-notify
rpcuser   4689     1  0 Aug30 ?        00:00:00 rpc.statd --no-notify
rpcuser   4698     1  0 03:16 ?        00:00:00 rpc.statd --no-notify
rpcuser   4836     1  0 Aug29 ?        00:00:00 rpc.statd --no-notify
rpcuser   4859     1  0 Aug30 ?        00:00:00 rpc.statd --no-notify
rpcuser   4867     1  0 Aug30 ?        00:00:00 rpc.statd --no-notify
rpcuser   4878     1  0 03:18 ?        00:00:00 rpc.statd --no-notify
rpcuser   5023     1  0 Aug29 ?        00:00:00 rpc.statd --no-notify
rpcuser   5037     1  0 Aug30 ?        00:00:00 rpc.statd --no-notify
rpcuser   5060     1  0 03:20 ?        00:00:00 rpc.statd --no-notify
rpcuser   5092     1  0 Aug30 ?        00:00:00 rpc.statd --no-notify
rpcuser   5211     1  0 Aug29 ?        00:00:00 rpc.statd --no-notify
rpcuser   5216     1  0 Aug30 ?        00:00:00 rpc.statd --no-notify
rpcuser   5227     1  0 Aug29 ?        00:00:00 rpc.statd --no-notify
rpcuser   5277     1  0 Aug30 ?        00:00:00 rpc.statd --no-notify

3 Answers 3

2

Most likely yourrpcbind service has not started :

sudo service rpcbind start
1
  • Issue with ports. Ports were not mapped to rpc bind in /etc/services. # cat /etc/services | grep rpc sunrpc 111/tcp portmapper rpcbind # RPC 4.0 portmapper TCP sunrpc 111/udp portmapper rpcbind # RPC 4.0 portmapper UDP
    – Pandu
    Commented Aug 31, 2017 at 16:05
1

Got the fix and it worked for my issue. check firewall rules, selinux status, port.

Stop the NFS services as below sequence

# service nfslock stop
# service nfs stop
# service rpcbind stop

Firewall rules:

Add required NFS ports to IPtables or disable IPtables

Selinux:

Disable selinux or add selinux context to the NFS files .

Port:

Below ports should be opened and mapped in /etc/services.

/root # cat /etc/services | grep rpc
sunrpc          111/tcp         portmapper rpcbind      # RPC 4.0 portmapper TCP
sunrpc          111/udp         portmapper rpcbind      # RPC 4.0 portmapper UDP

finally, start the service in below sequence

# service rpcbind start
# service nfs start
# service nfslock start
1
  • Actually ports were not mapped to rpcbind in /etc/services
    – Pandu
    Commented Aug 31, 2017 at 15:16
0

10/13/19 newly installed Kubuntu 18.04 exhibited this old flaw. no network problems with other distributions or the Kubuntu 14.04 I replaced.

gregsat:/mnt/_$showmount -e

clnt_create: RPC: Program not registered

"sudo service nfs-kernel-server restart" or "...rpcbind..." didn't help

edited /etc/exports: just cleaned up some old commented out exports and restarted nfs-kernel-server but fixed rpc flaw

gregsat:~/_$sudo service nfs-kernel-server restart

gregsat:~/_$showmount -e

Export list for gregsat:

/mnt/usb1 192.168.113.58

/home 192.168.113.78,192.168.113.58,192.168.113.38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .