I have the following PHP packages installed on my CentOS 5.6 host and I am trying to install php-posix. When I run yum install php-posix I receive an error saying that php53-common conflicts with php-common.

[root@dev ~]# yum list installed | grep php
php.x86_64                               5.3.10-1.w5                   installed
php-cli.x86_64                           5.3.10-1.w5                   installed
php-common.x86_64                        5.3.10-1.w5                   installed
php-devel.x86_64                         5.3.10-1.w5                   installed
php-gd.x86_64                            5.3.10-1.w5                   installed
php-ldap.x86_64                          5.3.10-1.w5                   installed
php-mcrypt.x86_64                        5.3.10-1.w5                   installed
php-mysql.x86_64                         5.3.10-1.w5                   installed
php-pdo.x86_64                           5.3.10-1.w5                   installed
php-pear.noarch                          1:1.9.4-1.w5                  installed
php-soap.x86_64                          5.3.10-1.w5                   installed
php-xml.x86_64                           5.3.10-1.w5                   installed

[root@dev ~]# yum install php-posix
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.krystal.co.uk
 * epel: ftp.uni-koeln.de
 * extras: mirror.krystal.co.uk
 * rpmforge: mirror.nl.leaseweb.net
 * updates: mirror.krystal.co.uk
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53-process.x86_64 0:5.3.3-7.el5_8 set to be updated
--> Processing Dependency: php53-common = 5.3.3-7.el5_8 for package: php53-process
--> Running transaction check
---> Package php53-common.x86_64 0:5.3.3-7.el5_8 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-7.el5_8.x86_64 from updates has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

What is preventing me from installing php-posix?


The error is caused by the php-common53 package conflicting with installed php-common package. The php-common53 package is version 5.3.3 while the installed php packages are 5.3.10. The installed php packages may have come from the EPEL or RPMForge repository. You can find out by running yum info php.

You will have to remove the php-common and dependent packages, and then install php53-common. You may lose some of the PHP packages you currently have installed if there is not a counterpart in the repository.

# yum remove  php php-cli php-common php-devel php-gd php-ldap php-mcrypt php-mysql php-pdo php-pear php-soap php-xml

When you install php-posix, the dependent packages such as php53 and php53-common will get installed automatically.

# yum install php-posix

You should be aware that having either or both EPEL and RPMForge repositories enabled can lead to problems if you aren't careful. Be familiar with the yum commands (such as --enablerepo and --disablerepo) and some of the available plugins (yum-plugin-protect-packages and yum-plugin-protectbase) to help manage the software and keep the repositories playing nice.

| improve this answer | |
  • I don't really want to have to remove all those packages, just to install php-posix that seems like quite an inconvenient way to upgrade one package. I don't want to move all my packages to php53-* either... – crmpicco May 18 '12 at 15:46
  • @crmpicco Understandable, but the package version conflicts is what is preventing you from installing php-posix, which answers your question. I did some digging and it appears the php-posix function is included in the package php53-process. No need to install the package php-posix. – George M May 18 '12 at 15:59
  • Yeah, I tried that too. Same issue though, i'm afraid. – crmpicco May 18 '12 at 16:13
  • Ah, well, you may have to downgrade to php53 to get it unless you can find another repository that is compatible. That's a bit of a slipperty slope. – George M May 18 '12 at 16:15
  • I've been given the solution to this, what I done was this: yum install php-process --enablerepo=webtatic Although, it updated all my PHP packages to 5.3.13 which isn't necessarily a bad thing. – crmpicco May 18 '12 at 17:02

I've been given the solution to this, what I done was this:

yum install php-process --enablerepo=webtatic

Although, it updated all my PHP packages to 5.3.13

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.