0

In gnome settings I can enable sharing and screen sharing but other than the ui gives me I don't have any control over the service.

I can't forward ports on the router because I'm using Internet provided by the landlord.

Trying to change settings through gconf does not seem to do anything:

[me@localhost]$ gsettings set org.gnome.Vino alternative-port 2000
[me@localhost]$ gsettings set org.gnome.Vino use-alternative-port true
[me@localhost]$ gsettings list-recursively org.gnome.Vino
org.gnome.Vino notify-on-connect true
org.gnome.Vino alternative-port uint16 2000
org.gnome.Vino disable-background false
org.gnome.Vino use-alternative-port true
org.gnome.Vino icon-visibility 'client'
org.gnome.Vino use-upnp true
org.gnome.Vino view-only true
org.gnome.Vino prompt-enabled true
org.gnome.Vino disable-xdamage false
org.gnome.Vino authentication-methods ['none']
org.gnome.Vino network-interface ''
org.gnome.Vino require-encryption false
org.gnome.Vino mailto ''
org.gnome.Vino lock-screen-on-disconnect false

[me@localhost]$ lsof -Pnl +M -i4 | grep vino
vino-serv 10862     1000   13u  IPv4 179445      0t0  TCP *:5900 (LISTEN)

Note that after changing the settings I pretended I was on Windows and tried rebooting to see if it had any affect. Then started sharing through the UI but it still listens to the same port.

Not sure where the process vino-serv is coming from as I am unable to locate it, execute it or start it as a service.

Maybe I can bypass the UI and start it manually with the right configuration or maybe there would be a much easier way.

Not sure if changing the port to an open port (most ports are closed on the router) and setting upnp to true will solve the port forwarding problem but right now I can't even try and see if it makes any difference.

{UPDATE]

Due to ali asgher answer I would like to add that even though the default config does not allow interaction (view-only) there will be situations where the viewer needs to take control over the desktop.

[UPDATE]

I used the chrome remote desktop add on and had to install some binaries on fedora:

sudo dnf install chrome-remote-desktop.x86_64 

================================================================================
 Package               Arch   Version              Repository              Size
================================================================================
Installing:
 chrome-remote-desktop x86_64 59.0.3071.104-1.fc25 updates                 10 M
 chromium-libs         x86_64 59.0.3071.104-1.fc25 updates                 50 M
 chromium-libs-media-freeworld
                       x86_64 59.0.3071.104-1.fc25 rpmfusion-free-updates 2.2 M
 xorg-x11-server-Xvfb  x86_64 1.19.3-1.fc25        updates                860 k

Still have to test it with someone to see if the other person can control my desktop.

1

Hey if you are sharing your screen on fedora. Maybe you can try one of those browser based screen sharing solutions like dead simple screen sharing here a link: https://www.deadsimplescreensharing.com/

  • Thank you for your reply, I was thinking of using google hangouts but don't think anyone can control your desktop. The config I show has view-only to true so it's not interactive by default but there will be occasions where I may need the viewer to control. – HMR Aug 30 '17 at 11:12
  • Seems that hangouts had that function but was discontinued and replaced by chrome remote desktop: chrome.google.com/webstore/detail/chrome-remote-desktop/… I will give it a try and hope it works without port forwarding. – HMR Aug 30 '17 at 11:21
  • For those not on debian, windows or mac but on cenos/fedora/redhat you can install the plugin in chrome and install remote desktop binaries with sudo dnf install chrome-remote-desktop.x86_64 – HMR Aug 30 '17 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.