When I resume from suspend-to-ram often the graphics on my internal screen is dim (around 30-50% intensity). Initially I thought it might be the backlight, but the mouse cursor is not dimmed - only everything else.

I also tried:

xbacklight -set 100
xbacklight -set 50

There is no change in the intensity of neither in the graphics nor the cursor.

A switch to another virtual terminal (CTRL-ALT-F2) and back (CTRL-ALT-F7) also did not change anything.

I attached an external screen and took a screen shot spanning both screens. The screen shot shows everything at full intensity.

xpdyinfo sees the two spanning screens as a single screen - thus does not treat the internal screen different.

Logging out and logging in again solves the issue, so it is clearly a software issue. The re-login seems to restart Xorg, but I would like to not have to re-login just to get the graphics on my screen un-dimmed.

Hardware: HP EliteBook 8540w
Software Ubuntu 11.10.
Window manager: xfce

How can I un-dim the graphics?

  • Do you have a tool that changes the gamma and/or other colour parameters for your internal screen? If it's an nVidia chip, there's nvidia-settings, but xgamma should work regardless. That may reset the CLUT on your card.
    – Alexios
    May 18, 2012 at 9:07
  • I tested xgamma: It only affects the external monitor when using -d :0. -d :1 does not work. Also if I try the darkest setting (-gamma 0.1) text written in white is not dimmed. Good guess, though. Xorg indicates it is a Radeon card.
    – Ole Tange
    May 18, 2012 at 15:27

2 Answers 2


I had this same issue on a Radeon card. Fixed it when it happened by tweaking the gamma setting in Catalyst Control Center. Worth a shot if you're able to install AMD's proprietary drivers on your system.

  • Can you confirm that your mouse cursor was not affected?
    – Ole Tange
    Oct 24, 2012 at 11:19
  • I sure can. Mouse cursor is not affected by my workaround; it remains at normal brightness. EDIT: Or do you mean if I was having the same problem (with the screen dim but not the mouse)? In this case, yes, I was having the same exact issue. Oct 25, 2012 at 0:26
  • Unfortunately I am not able to install the proprietary driver. But fortunately I have not seen the dimming for a long time. Maybe it is a fixed bug in Xorg.
    – Ole Tange
    Oct 30, 2012 at 14:13

I reactivated ATI control in 'colour' section of catalyst Control Centre on my Radeon HD 3450 (Dell S2009W) (Win. Vista) graphics card. Fixed it straight away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .