3

According to xrdp docs it should be possible to connect remotely without using a local VNC server:

xrdp can connect to a locally created X.org session with the xorgxrdp drivers [my emphasis], to a VNC X11 server, and forward to another RDP server.

I can connect with RDP from Windows:

enter image description here

Then I select Xorg session and supply username and password. After some timeout an error pops up about an unknown connection problem.

enter image description here

This is tail /var/log/xrdp.log and tail /var/log/xrdp-sesman.log output:

[DEBUG] Closed socket 17 (AF_UNIX)  
...  
[DEBUG] Closed socket 17 (AF_UNIX) 
[DEBUG] xrdp_wm_log_msg: some problem  
[DEBUG] xrdp_mm_module_cleanup  
[DEBUG] Closed socket 16 (AF_INET6 ::1 port 38094)

enter image description here

dmesg doesn't show any problems nor references to Xorg or similar. ps -A | grep rdp shows xrdp and xrdp-sesman processes running. Tried connecting with Windows 7 to Debian: same problem. xrdp.ini and sasman.ini:

In sesman.ini the AlwaysGroupCheck=false. The startwm.sh:

startwm.sh

Any ideas? Running on a virtualized minimal, clean Debian 9.1 installation. Only only lxde-core and xrdp installed with apt-get. (No errors during installation.) xorgxrdp drivers installed (since they depend on xrdp).

  • Did you compile xrdp and xorgxrdp from source? xrdp must be compiled and installed before xorgxrdp. If not what versions? What desktop are you using? You may want to install lxde desktop to help with debugging. xrdp.ini and sesman.ini using default settings? What about var/log/xrdp-sesman.log Strange error in xrdp log "some problem"... Does dmesg have any useful info? – jc__ Aug 29 '17 at 14:40
  • @jc__, I didn't compile. I first installed lxde-core. Then, once logged in, installed xrdp which has a dependency on xorgxrdp. I'll update the question with other logs. – Davor Josipovic Aug 29 '17 at 15:27
  • Lets do some background checking: Verify the services are running ps -A | grep rdp. You should see both xrdp and xrdp-sesman. You are using the selection Xorg, so check the Xorg in xrdp.ini. Should be libxup.so library, ip=127.0.0.1 port=-1 then check the Xorg section in sesman.ini these are the parameters passed to Xorg. Note the log name. param=.xorgxrdp.%s.log. see your home directory for that log. – jc__ Aug 29 '17 at 17:44
  • In sesman.ini verify the AlwaysGroupCheck= if false the login user does not need to be in the group assigned by TerminalServerUsers= – jc__ Aug 29 '17 at 17:46
  • Oh yeah, What version of windows are you connecting with? If its above 7.. might be a problem. I had to compile with the --enable-painter option to make work with Win10. – jc__ Aug 29 '17 at 17:53
8

This bug report has the same symptoms as described in the question. Seems xserver-xorg-legacy package is the culprit. So to make it work, it boils down to the following two commands:

apt-get purge xserver-xorg-legacy
apt-get install xrdp

The required services are started automatically after install. No need to reboot. Connecting and authenticating should automatically show the desktop.

I do not know though what the consequences are of removing xserver-xorg-legacy. In the bug report it is mentioned to remove if not needed.

0

You can refer to the question!

Attention: you need to use dpkg-reconfigure xserver-xorg-legacy command to change the setting in debian 9.

  • 1
    Welcome to StackExchange. Your referenced questions doesn't contain the quoted text. Can you explain why dpkg-reconfigure xserver-xorg-legacy is needed? – Davor Josipovic Oct 25 '18 at 19:35
0

Initially, I could only access my Debian 9.6.0 LXDE desktop with tigervnc using the Xvnc settings until I changed the file /etc/X11/Xwrapper.config from:

allowed_users = console

to

allowed_users = anybody

Now, I can RDP using the Xorg settings without the tigervnc. Hope this will be helpful to someone.

There was no need to use any of the recommended answers here...

And don't forget...

sudo service xrdp restart

...to restart the xrdp service after editing the Xwrapper.config file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.