0

am running whonix inside virtual machine.

Last time I have added debian testing and unstable repositories, than installed firejail from testing, made apt-get update and also apt-get upgrade, and got black screen after reboot.

I saw this picture when tried to log in using console: enter image description here

File /etc/ld.so.preload was empty, I removed it, errors left screen but black screen still here.

I don't know how to fix it.

If I am pressing Host+F1, then logging and do:

sudo apt-get update && sudo apt-get dist-upgrade

I will see very weird picture: enter image description here

last kernel log in attachment

  • kernel log i.stack.imgur.com/n6nZP.png – ValueError Aug 29 '17 at 4:42
  • Welcome to U&L , please edit your question by adding the output of cat /etc/apt/sources.list and cat /etc/apt/sources.list.d/* (a text format is better than an image) – GAD3R Aug 29 '17 at 9:12
  • Thanks a lot for reply and affability dear, I appreciate your efforts and help. Just a min I will try to do that. Text format is problem because clipboard not works (GUI not works, only console), but I will try to find workaround. Thanks. – ValueError Aug 29 '17 at 10:35
  • 1
    first command - file not found, second pastebin.com/1qshE5d7 – ValueError Aug 29 '17 at 10:41
  • 1
    /etc/apt/sources.list.d/debian.list /etc/apt/sources.list.d/whonix.list – ValueError Aug 29 '17 at 10:48
0

Remove the following source:

rm /etc/apt/sources.list.d/debian.list
rm /etc/apt/sources.list.d/user.list

Use the command history to identify the installed package from unstable(eg: firejail) then remove it through apt-get remove firejail. also remove the apparmor package which cause a problem.

then run:

apt-get update && apt-get upgrade 
apt-get -f install
reboot
  • Thanks a lot for your help! not works :( here is result of history output: pastebin.com/Hjv63E4P I tried to remove firejail as you said in instruction, no changes, still here black screen after reboot – ValueError Aug 29 '17 at 11:13
  • nano /etc/apt/preferences.d/my_preferences keep only the stable and set the pin to 1001 Pin-Priority: 1001 then run apt dist-upgrade – GAD3R Aug 29 '17 at 11:19
  • do I need to remove pins numbers for unstable and testing? – ValueError Aug 29 '17 at 11:21
  • Yes , it is not recommended to use a mixed package from stable , testing and Sid , your system became unstable (or bricked) – GAD3R Aug 29 '17 at 11:23
  • I have made changes as you said, then rebooted, and black screen still here – ValueError Aug 29 '17 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.