I have an installation of alpine linux running in a virtualbox vm with slim + xfce4 for the desktop engine.

Kernel Version: I have tried with both the latest (3.6.2) Standard and Virtual Kernel from https://alpinelinux.org/downloads/

I have not been able to get the guest to utilize the entire screen resolution, instead it is only able to go up to 1024x768. I was wondering if anyone could help me figure out what I'm missing/doing wrong. Below are the steps I've taken:

I followed the steps in this video exactly

Standard Alpine Linux install

  • Using all repositories: apk update && apk upgrade
  • setup-xorg-base
  • apk add alpine-desktop
  • apk add xfce4
  • apk add thunar-volman
  • apk add faenza-icon-theme
  • apk add slim
  • rc-service dbus start
  • rc-update add dbus
  • rc-service udev start
  • rc-service add udev
  • rc-update add slim
  • reboot

Virtualbox Specific Packages:

Standard Kernel:

apk add virtualbox-guest-modules-grsec virtualbox-additions-grsec virtualbox-guest-additions-5.1.26-r0

Virtual Kernel:

apk add virtualbox-guest-additions-5.1.26-r0 apk add virtualbox-guest-modules-grsec "apk add virtualbox-guest-modules-grsec" give the following warning message:

depmod could not open /lib/modules/4.9.44-0-hardened/modules.order

I did NOT do the following:

apk add virtualbox-additions-grsec Because that breaks my installation, only allows me to boot into the command prompt and spams the following error:

tty port_close_start: tty->count = 1 port count = 2

Virtualbox Settings:

  • Version: 5.1.26 r117224 (Qt5.6.2)
  • VirtualBox > Preferences > Display > Maximum Guest Screen Size: None
  • View > Auto-resize Guest Display checked (It's greyed out, can't select it)
  • VM Settings > Display > Screen: Video Memory 128MB, 1 Monitor, 100% scale factor, Enable 3D Acceleration turned on

I solved this problem by following the steps below.
Display screen graphics controller (G): VBoxSVGA selected.

$ sudo apk add xf86-video-vboxvideo xf86-video-intel xf86-video-vesa  
$ sudo apk add xf86-input-synaptics  
$ sudo apk add virtualbox-guest-additions  
$ sudo rc-update add virtualbox-guest-additions default  
$ sudo echo vboxpci    >> /etc/modules  
$ sudo echo vboxdrv    >> /etc/modules  
$ sudo echo vboxnetflt >> /etc/modules  

$ sudo apk update  
$ sudo apk upgrade --update-cache --available  

$ sudo reboot  
  • sudo echo normally doesn't work.  Is that really what you did? – Scott Nov 15 '19 at 23:41

The steps I actually took were a little different.
Thank you for your comments.

I solved this problem by following the steps below.
Display screen graphics controller (G): VBoxSVGA selected.

# apk add xf86-video-vboxvideo xf86-video-intel xf86-video-vesa

# apk add xf86-input-synaptics

# apk add virtualbox-guest-additions

# rc-update add virtualbox-guest-additions default

# echo vboxpci >> /etc/modules

# echo vboxdrv >> /etc/modules

# echo vboxnetflt >> /etc/modules

# apk update

# apk upgrade --update-cache --available

# reboot

  • Please get your accounts merged, edit your other answer and delete this one. – Scott Nov 16 '19 at 2:08

Maybe you should check your first line beginning apk should you have not written GUEST Your line reads as follows

apk add virtualbox-additions-grsec

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.