0

OS: Manjaro, Gnome 3 version

Audio interface: M-audio fast track pro (USB interface)

Microphone: Condenser (48V phantom power) (the model is behringer C-3), connected via XLR

When I try to record in linux with jack in audacity (manjaro, jack2, started through cadence), I get an huge gain compared to the level I expect to see in windows. Even just talking near my mic at low gain on my soundcard (m-audio fast track pro) causes it to clip. At my usual gain on my soundcard, I get a -12db noise floor (and any actual sound at all clips).

If I turn the knob to the absolute minimum and I sing far from my microphone, I get an almost reasonable volume, but it's very obvious that I'm only getting an handful of bits of depth.

I know the information is probably not sufficient, but I'm not sure what I could add. Let me know.

EDIT: When I booted up my system this morning, the problem changed. I now clip only at full gain on my audio interface, but the bit crush effect is even worse. So now it looks like the audio is doing something like discarding the least significant byte and then shift to the right a bunch of bits? I have no idea anymore.

EDIT: As requested in a comment

$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7130000 irq 30
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17
 2 [Pro            ]: USB-Audio - FastTrack Pro
                      M-Audio FastTrack Pro at usb-0000:00:1d.0-1.5, full speed

$ amixer -c2 contents
numid=3,iface=PCM,name='Capture Channel Map'
  ; type=INTEGER,access=r----R--,values=2,min=0,max=36,step=0
  : values=3,4
  | container
    | chmap-fixed=FL,FR

numid=1,iface=PCM,name='Playback Channel Map'
  ; type=INTEGER,access=r----R--,values=2,min=0,max=36,step=0
  : values=3,4
  | container
    | chmap-fixed=FL,FR

numid=4,iface=PCM,name='Capture Channel Map',device=1
  ; type=INTEGER,access=r----R--,values=2,min=0,max=36,step=0
  : values=0,0
  | container
    | chmap-fixed=FL,FR

numid=2,iface=PCM,name='Playback Channel Map',device=1
  ; type=INTEGER,access=r----R--,values=2,min=0,max=36,step=0
  : values=0,0
  | container
    | chmap-fixed=FL,FR
  • 1
    Check a(lsa)mixer. There could a gain control. Make sure you press F6 to pick the right card and F4/F5 to show the capture controls, if you check it with alsamixer. FWIW jack doesn't do anything to volume. – Tom Yan Aug 29 '17 at 1:04
  • alsamixer says that there are no controls for my audio interface. In my "sound settings" (I'm not actually sure what the application is exactly called) there is a gain, but it's at 100%, and the weirder problem I'm having this morning doesn't seem to get better if I mess with that. – user247427 Aug 29 '17 at 6:08
  • Just in case: You selected the correct card in alsamixer? Easy to forget if you don't know it. If that doesn't help, please edit question with output of cat /proc/asound/cards, and amixer -c42 contents, where 42 is the card number of the M-audio. If that is too long, put it in a pastebin. – dirkt Aug 29 '17 at 9:47
  • I selected the correct card in alsamixer using the F6 menu. I also added the logs you asked, let me know if they're too long and would fit better in a pastebin. – user247427 Aug 29 '17 at 10:56
0

More info, like which Unix OS you are using (Ubuntu, Fedora, Debian) or microphone type (dynamic, condenser) and how it connects to your sound card (3.5mm jack like earbuds jack for MP3 players, 1/4 inch plug, USB, XLR cable with or without interface?) would be nice to see. But in the meantime...

I had the opposite problem with Audacity and my Audio Technica 2005USB dynamic mic. The gain was almost completely nothing! Starting with Audacity closed, after plugging the mic in I clicked the gear icon of Ubuntu 16.04 and clicked System_Settings>Sound. (This is where it would be helpful for us to know your OS, but no worries. If you're smart enough to use Linux, you're smart enough to figure how to get to your OS's audio settings! :-D ) In the sound settings window I switched the Input to the newly plugged in mic. Immediately I saw an analog VU-meter style bar graph showing the intensity of the current sound being put into the mic. After speaking "TEST... 1. 2. 3." into the mic at a clear, normal speaking level, the bar graph only lit up about two of the 30 bars on the bar graph. Above the bar graph was a slider adjustment labeled Input Volume. Making small adjustments while speaking the "TEST... 1. 2. 3." into the mic I found where the bar graph was lighting into the 75 to 80% range. Then I opened Audacity and made sure the input for Audacity was selected to be the same mic device. (BTW: If you have headphones on or speakers on, turn them down so you don't damage your hearing!) Speaking "TEST... 1. 2. 3." showed on the audio bar of Audacity jumping into and staying in the red as I spoke. So I jumped back and forth between my OS's Audio settings and Audacity, adjusting the Input Volume until "TEST... 1. 2. 3." just barely, occasionally dipped into the red zone on Audacity's Recording Level meters at the top of the Audacity window. That is called "setting mic level". After the mic level was set, I recorded some scratch sentences and played it back. It sounded fine!

Try fiddling around with the audio settings and see if lowering your system's input volume adjustment improves the sound quality. If not, shoot us some more info. Someone else may have an idea about quirks related to your specific OS, sound card or system.

  • I updated my post with OS, audio interface and microphone. I also added the problem I started experiencing this morning. It almost seems like the audio interface is applying random processing depending on its mood. – user247427 Aug 29 '17 at 6:01
  • Looked at M-Audio manual. Let's check things: (1) POWER: AC wall adapter? USB? USB hub? what version? Different power limits to USB 1, 2 and 3. M-Audio's manual says wall adapter is "9V DC 500 mA". USB 1 and 2 provide 500 mA and USB 3 900 mA, but all USB voltage is 5V DC. (2) Is the 48V red light on the panel bright? Phantom switch is on back panel. (3) Plug headphones into jack on M-Audio. Are you getting good sound in headphones? Monitor volume is above the jack and set the A/B switch the right way. If (1), (2) and (3) check, then power, mic, XLR cable and pre-amp are good. – grep_it Aug 29 '17 at 17:47
  • (1) I'm using the AC wall adapter. (2) The 48V red light is bright. (3) I'm using HD598 headphones and they sound fine. I tested monitoring and the mic sounds exactly as I would expect directly when I turn the monitor knob to the left, both in my headphones and in the outputs I use for my nearfield monitors. Thanks for all the help you're giving me! :) – user247427 Aug 29 '17 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy