3

I am a new Linux user and am struggling installing a driver for a usb WiFi device I want to use on an embedded system (BeagleBone).

When I download the driver for the chipset (Ralink 2070), it is provided as a bin file. I have tried making it executable (chmod +x), but using file says it is a data file and I cannot execute.

How do I use this bin file to install the chipset driver? Do I only need to place this in a folder, and if so, where should it be placed?

  • Where did you get this driver? – Shawn J. Goff May 17 '12 at 22:17
  • Thanks everyone for the help! The compatibility page I downloaded the driver from listed the bin as a driver, but modprobe proved it a firmware. – user18988 May 18 '12 at 1:28
3

I suspect what you have is a firmware, rather than a driver. Try placing it in /usr/lib/firmware. I believe the driver for that device is rt2800usb, so after the firmware is in place, run modprobe rt2800usb. If modprobe complains about not finding the driver, you'll have to compile it, and that deserves a separate question.

  • Thanks shawn for the reply! I tried placing that file in the folder and ran modprobe. The message returned said that the bin was not found, so it looks like it is indeed firmware. I will try compiling and submit another question if need. Thanks again! – user18988 May 18 '12 at 1:15
0

If file says it's a data file (as opposed to an executable file), something looks quite wrong here: maybe the file is a firmware rather than a driver?

  • 1
    file would identify it as an x86 executable if that were the case. – psusi May 17 '12 at 23:48
  • I see. Edited my answer to remove that. – Renan May 17 '12 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.