9

I'm running Debian as host and I fail to get Debian, Ubuntu, and Fedora guests to be fullscreen. Changing video memory didn't help.

NOTES:

  • I haven't tried any other distro
  • I didn't create WinXP guest myself
11

There are a few things that need to be in place. You need to have guest additions installed on the guest OS. You have to have "guest display auto-resize" feature enabled (Host+g toggles this), and then you have to actually activate full-screen mode (Host+f toggles this).

Specifically, on the Debian/Ubuntu guest, run the following (as root):

apt-get install virtualbox-ose-guest-x11
13
  • Guest additions not being installed is almost certainly the problem – Falmarri Nov 9 '10 at 19:06
  • Agreed with Falmarri. Most distributions have the guest additions in the repositories, so you can look there first. – Shawn J. Goff Nov 9 '10 at 19:18
  • I followed the instructions and now I got "Disable Guest Display Auto-resize" and it's not selectable. Any ideas? – tshepang Nov 9 '10 at 21:49
  • Are you sure you installed the guest additions correctly? You compiled/installed/restarted? – Falmarri Nov 9 '10 at 23:55
  • @Fal, must I restart the host as well? – tshepang Nov 10 '10 at 1:04
-1
sudo -i
sh /media/cdrom/VBoxLinuxAdditions.run uninstall

reboot‍

sudo -i
sh /media/cdrom/VBoxLinuxAdditions.run
2
  • What CD is that on? – G-Man Says 'Reinstate Monica' Jul 3 '15 at 16:37
  • This question is already answered and with it's age you need to provide more detail. I'm recommending deletion 4 now. – eyoung100 Jul 3 '15 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.