0

Several times I updated pacman -Syy , pacman -Syu and some other commands. I have multilib source uncommented in pacman.conf. My last thoughts were about pacman-key, I was trying to change keyserver in /etc/pacman.d/gnupg/gnu.conf, run pacman-key --refresh-keys and pacman-key --populate archlinux but it didn't help me. Was googling a lot, but I guess I need to ask here. pacman -S xorg works, but pacman -S yaourt and several others not

UPD: pacman.conf

 #
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#Color
#TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Never
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Trying to install

 sudo pacman -S light 
 error: target not found: light 
 sudo pacman -S alsamixer
 error: target not found: alsamixer   

closed as unclear what you're asking by jasonwryan, Anthon, Stephen Rauch, Rui F Ribeiro, Scott Aug 29 '17 at 4:02

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • yaourt is not in the official repositories, so pacman will not find it. Read how the AUR works. – jasonwryan Aug 27 '17 at 19:10
  • But it was only an example. I also cannot install alsamixer, xbacklight and another apps. – Dmytro Osaulenko Aug 27 '17 at 19:16
  • Paste your pacman.conf and the full command and output. – jasonwryan Aug 27 '17 at 19:42
  • Pasted conf and commands – Dmytro Osaulenko Aug 27 '17 at 20:18
  • 1
    There is no package "light" nor "alsamixer". Paste the output of pacman -Syu alsa-utils. – jasonwryan Aug 27 '17 at 20:45
2

To install yaourt , open the terminal and run

git clone https://aur.archlinux.org/package-query.git
cd package-query
makepkg -si
cd ..
git clone https://aur.archlinux.org/yaourt.git
cd yaourt
makepkg -si
cd ..

Save and run;

sudo pacman -Sy yaourt base-devel fakeroot
yaourt -Syu --devel --aur

alsamixer is a part of alsa-utils , light package should be installed from AUR

  • 1
    That repo is full of broken packages: advising anyone ot enable it is doing them a disservice. – jasonwryan Aug 27 '17 at 20:43
  • @jasonwryan i have used this repo for a long time , I don't know that – GAD3R Aug 27 '17 at 20:50
  • @jasonwryan can you provide some link , please – GAD3R Aug 27 '17 at 20:51
  • 2
    There is no single link, there is a long history of broken packages documented on the boards and on IRC... – jasonwryan Aug 27 '17 at 20:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.