4

I have a fresh installation of Fedora 26 in VMWare Player (uname -a: Linux localhost.localdomain 4.12.8-300.fc26.x86_64 #1 SMP Thu Aug 17 15:30:20 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux) and my first action after set up was to install Chromium. But starting Chromium did not work. I reinstalled Fedora 26 from netinstall again and installed Chromium again. But I couldn't start Chromium again.

The installation itself worked without any errors.

I can see that Chromium is in the top bar of Gnome where the active application is shown but the window of Chromium does not appear. After a few seconds I clicked on the entry in the top, Fedora 26 asks me to kill the application because it's not responding.

I installed Fedora using the official fedora repositories. As requested:

[tjati@localhost ~]$ chromium-browser --version
Chromium 60.0.3112.101 Fedora Project

How can I use Chromium?

9
  • If the installation failed, how do you expect to use Chromium? Please edit your question with the error's shown during installation. Commented Aug 27, 2017 at 14:22
  • @Hunter.S.Thompson I edited my post and made clear that the installation itself worked but not starting Chromium itself.
    – tjati
    Commented Aug 27, 2017 at 14:27
  • Are you installing Chromium from the fedora repo? Can you run the command chromium --version and add the output to your question. Commented Aug 27, 2017 at 14:32
  • Yes and I added the output you asked for.
    – tjati
    Commented Aug 27, 2017 at 14:38
  • 1
    What does it say whey you just run chromium-browser in the terminal? Maybe it's saying something. Maybe even in dmesg/syslog.
    – Xen2050
    Commented Aug 27, 2017 at 14:46

2 Answers 2

1

Unfortunately you'll have to disable 3D acceleration within the VMware host settings. That was the only way I was able to get it to launch properly.

1
  • A reinstall of fedora was required, but now it works.
    – tjati
    Commented Sep 24, 2017 at 8:01
0

As per Xen2050's instructions, I tried this - and it gave the answer for me. You can’t run Chromium as root with no sandbox.

Logged out as root and back in as a user, worked OK.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .