0

I update apt packages, and see that there is a package which can be updated because of the following notice.

1 package can be upgraded. Run 'apt list --upgradable' to see it.

Options are

  1. to update to the version libreoffice-sdbc-firebird/stretch-backports 1:5.4.0-1~bpo9+1 amd64.
  2. to prevent the notice

Code to reproduce the notice

masi@masi:~$ sudo apt update
...
Hit:15 http://cdn-fastly.deb.debian.org/debian stretch Release
Reading package lists... Done
Building dependency tree       
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.

Seeing the list of packages where to choose the package to be updated and current status

masi@masi:~$ apt list -a --upgradable
Listing... Done
libreoffice-sdbc-firebird/unstable 1:5.4.0-1 amd64 [upgradable from: 1:4.3.3-2+deb8u7]
libreoffice-sdbc-firebird/stretch-backports 1:5.4.0-1~bpo9+1 amd64
libreoffice-sdbc-firebird/now 1:4.3.3-2+deb8u7 amd64 [installed,upgradable to: 1:5.4.0-1]

1. Trying to update a package to unstable

Doing but conflicts so option (2) seems to be better

masi@masi:~$ sudo apt install libreoffice-sdbc-firebird/stretch-backports
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Selected version '1:5.4.0-1~bpo9+1' (Debian Backports:stretch-backports [amd64]) for 'libreoffice-sdbc-firebird'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libreoffice-sdbc-firebird : Depends: libreoffice-core (= 1:5.4.0-1~bpo9+1) but 1:5.2.7-1 is to be installed
                             Depends: uno-libs3 (>= 5.3.0~alpha) but 5.2.7-1 is to be installed
E: Unable to correct problems, you have held broken packages.

2. To prevent this notice

I think it can be better to keep the current package but keep the notice for a while. Maybe with equivs and particularly equivs-control.

OS: Debian 9.1
Related: Apt update says a package can be upgraded but upgrade says the opposit

1

To install the libreoffice-sdbc-firebird (available only on stretch backports) you should upgrade the libreoffice-core and uno-libs3 from backports.

sudo apt install -t stretch-backports libreoffice-core uno-libs3
sudo apt install -t stretch-backports libreoffice-sdbc-firebird
  • What is the purpose of the second line? – Léo Léopold Hertz 준영 Aug 27 '17 at 11:37
  • I already run the second command with -t stretch-backports. How can you revert back to stable libreoffice-sdbc-firebird? It says me The following packages have unmet dependencies: libreoffice-sdbc-firebird : Depends: libreoffice-core (= 1:5.4.0-1) but 1:5.4.0-1~bpo9+1 is to be installed Depends: libfbclient2 (>= 3.0.2~) but 3.0.1.32609.ds4-14 is to be installed when trying to run the second command now. – Léo Léopold Hertz 준영 Aug 27 '17 at 11:39
  • 1
    libreoffice-sdbc-firebird isn't available for debian stretch (stable) – GAD3R Aug 27 '17 at 11:41
  • What is the output of apt-cache policy libreoffice-sdbc-firebird? – GAD3R Aug 27 '17 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.