4

There was as power outage while I was making a copy of my Debian's virtual disk in my Windows host. Now, when started, the system shows the message:

/dev/sda1: recovering journal    
/dev/sda1: clean, 247572/393216 files, 1424558/1572608 blocks

And stays in this terminal screen. I tried the solution I read in this post on AskUbuntu, and in some others threads, but nothing has solved the issue so far. My attempt was to boot to the GRUB menu and recovery mode, and as root: umount /dev/sda1 and then fsck -f /, which showed all the 5 passes and the message:

/dev/sda1: 247576/393216 files (0.2% non-contiguous), 1425073/1572608 blocks

But when rebooting the system, the same message "recovering journal" is shown and nothing else loads. I also tried reinstalling gnome-core, but sudo apt-get install gnome-core gives me lots and lots of Failed to fetch errors. What can I try to get the system to work as before?

7

1 Answer 1

3

The probability of multiple inconsistencies in the disk image file due to the power failure are very high.

As the behaviour is not a good sign, I would not sink time trying to recover something with such a low change of success.

Recover what you can of /home, and create/reinstall the VM.

1
  • 1
    Yes, that seems the appropriate thing to do. I did exactly that, using the live CD for recovering the files. Thanks! Commented Aug 27, 2017 at 14:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .