I currently have an issue where I can no longer get my right mouse click to work on my laptop trackpad.

70-synaptics.conf: https://pastebin.com/rStE3d2F

cat /proc/bus/input/devices: https://pastebin.com/SD62xeJg

xinput: https://pastebin.com/CS9WPRr4

evdev: https://pastebin.com/HGZeCVPr

I've tried uninstalling synaptics/libinput and reinstalling both at seperate times, and can't get anything to work. I though that evdev was being used, but cat /proc/bus/input/devices indicates that I'm using synaptics... and also I think that that is set up right. I'd guess hardware but the trackpoint works fine on my other boot (Windows).

Does anybody have any ideas?

  • /proc/... tells you about the name of the kernel driver. The choice between synaptics/libinput is outside the kernel, it is an X11 thing. It does not affect the kernel synaptics driver. A bit confusing I know :-). If you use Wayland instead of X11, it will always use libinput.
    – sourcejedi
    Jul 21, 2019 at 19:36

3 Answers 3


I was having the same problem on my Lenovo laptop running Arch Linux.

I installed the package xf86-input-synaptics, restarted system and now it works.


In a previous deleted answer, I mentioned how I was able to install libinput on a machine that does not have it. This, of course, was a response to another question on another site and I made an error in answering here instead.

Here is the solution that worked for me.

  1. Open GNOME Tweaks (you may need to download it)
  2. Go to Mouse and Keyboard
  3. Under Mouse Click Emulation, select Area.
  • Not a problem! I've no longer got access to this machine but the answer was very elusive, so hopefully, this will still help people. Apr 17, 2018 at 16:39

have you tried using only libinput?

I see that you are using gnome and maybe is a problem with wayland, which does not have a good support for synaptics.

Try uninstalling both synaptics and libinput, then install just libinput and reboot your system.

  • Unfortunetly that has not worked either. I also tried uninstalling both and the mouse still worked. Though locating synaptics still returns the xorg.confs, I'm unsure if they're deleted anyway though.Could it be that im using evdev? Aug 26, 2017 at 21:50
  • Sorry my mistake, they are not there anymore. locate synaptics | grep xorg just tells me that they are. Aug 26, 2017 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.