5

Soft Lockup

dmesg reports in my laptop, since quite some time now, NMI watchdog: BUG: soft lockup every time I try to use updatedb or firefox. Samples of what is reported posted at https://github.com/zfsonlinux/zfs/issues/4536#issuecomment-280894134.

Related questions are

I have also read/commented at - https://github.com/zfsonlinux/zfs/issues/4536

Question

How can I detect whether it's a hardware issue or, as I think, confirm it's an issue related to the kernel/software?


Details

Linux Distribution

Funtoo-Linux, a rolling distribution

Kernels

I have (at least) observed the "BUG" while using the following kernel(s) versions:

pf

  • 4.11_p4-pf
  • 4.8_p8
  • 4.5_p4

ck

  • 4.12.7-ck

debian

  • lts-4.9.30
  • 4.8.x
  • 4.7.8

Configuration

I use a custom configuration to compile the kernel. It's mostly the same configuration I use(d) for long time, when there was no "soft lockup" problem or whatsoever related to a "watchdog".

I can copy-paste or link the configuration file. However, two important settings I have found else to be "required"

CONFIG_KALLSYMS=y
CONFIG_PREEMPT_NONE=y

ZFS

I observed the "BUG" while using ZoL versions

  • 0.6.5.11
  • 0.6.5.10
  • 0.6.5.9
  • 0.6.5.8
  • 0.6.5.3
8
  • NMI by definition is a hw interrupt; it manifesting itself only on those two programs, could it be load related, have you tried other heavy I/O programs? Aug 25, 2017 at 8:59
  • 1
    @RuiFRibeiro The OP is not asking what NMI is but what caused the watchdog to be woken up (IOW what caused the kernel to be stuck)
    – xhienne
    Aug 25, 2017 at 9:37
  • 1
    @RuiFRibeiro I really want to know whether my laptop needs a hardware service or if I am messing too much with my custom kernel configurations. But, yes, I got the "BUG" also once using a simple find command that was finding too many files. Aug 25, 2017 at 12:17
  • @RuiFRibeiro And if useful, I have tried (in the past) an Ubuntu-Live version. It did not cause the CPU to stale. Aug 25, 2017 at 12:20
  • 1
    @RuiFRibeiro To learn and have fun with it in the beginning. Now because it's neat! See also funtoo.org/ZFS_Fun. Aug 25, 2017 at 13:22

1 Answer 1

0

Whilst it could be a hardware problem, however due to the code maturity of the ZFS code for Linux, and a whole slew of people complaining of your very same message in multiple versions, I am inclined to say that is a software bug.

There have been multiple bugs about race conditions in the ZFS code, and truth is that is not still entirely trustworthy for production systems.

If that notebook of yours is a playground/testing system, a good ZFS test to possibly rule out software versus hardware problems would be trying ZFS+FreeBSD, which has a more tested and stable codebase.

If you also had in the past a known stable config with Linux+zfs, as per your aditional comments, it could be a good idea to go back and test it, for ruling out possible problems.

As for trying to debug the actual kernel level code, you could try sysdig but if the system hangs, it is possible it dies on you before spewing logs that can lead to the root of the problem (or not).

8
  • Thank you. This is meant to be a way to test for hardware vs. software? Is there really no other way to capture what's going on behind the scenes? Aug 25, 2017 at 16:11
  • This unix.stackexchange.com/q/157413/13011 I wrote when there was no problem. Perhaps I should try to get that kernel (3.x.x) and ZFS (0.6.3) running again? Aug 25, 2017 at 16:12
  • Sorry, did read well your comment. added to the answer. Aug 25, 2017 at 16:26
  • 1
    I will try yet with another live version, which supports for ZFS. Sep 1, 2017 at 13:32
  • 1
    Tried with an Lubuntu Live USB. There is no problem "there". Firefox is working properly, updatedb as well. Importing my "zpool" worked flawlessly. The blame is on me and the custom kernel configuration I use. Of course, I don't know what exactly is my wrongdoing. Nov 3, 2017 at 10:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .