6

I am on Antergos with GNOME 3.24.3.

Pressing the Super key (Windows key) opens this Activities menu/view that I don't want to use:

Activities menu

Pressing the Super + A keys opens the menu that I want to open with just the Super key:

enter image description here

I have attempted to set this myself by using dconf-editor to set the Activities menu to the Alt_R key (a key I never use) and the Show All Applications menu to the Super key.

(The keybinding for the Activities menu is under /org/gnome/mutter/overlay-key. The keybinding for the Show All Applications menu is under /org/gnome/shell/keybindings/toggle-application-view.)

However, pressing Super or Super + A does nothing now.

How can I make this all work?

1
4

Not sure why you couldn't get it working with those dconf settings. This works for me (in Ubuntu 18.04):

gsettings set org.gnome.mutter overlay-key ''
gsettings set org.gnome.shell.keybindings toggle-application-view "['Super_L']"
0
4

In my case I needed to figure out which key was mapped to the physical super key.

  1. Launch Settings -> Region & Language.
  2. Click on the Input Sources list and choose a language (in my case it was English).
  3. Click on the little "keyboard" button in the right corner of the window and launch "Show keyboard layout".
  4. Click Super button and figure out that it's mapped to Super_R
  5. Run gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "['Super_R']"

All good now!

4
  • 1
    I Click "Super_L" button in the layout and nothing happends, but just using "Super_R" instead of "Super_L" make it work. Great!
    – m3nda
    Aug 9 '19 at 0:17
  • 1
    @erm3nda you can launch tweaks and flip Super_L to Super_R as well (goto Keyboard & Mouse -> Overview Shortcut)
    – Asalle
    Aug 9 '19 at 8:58
  • As far as i remember, the keyboard shortcuts do only accept a combination of keys, so i was not able to just set it to "Super_L" or "Super_R" as is. That's why i ended up using gsettings.
    – m3nda
    Aug 10 '19 at 22:00
  • it's not the standard keyboard shortcuts app, it's the tweaks app (wiki.gnome.org/Apps/Tweaks). It basically is the graphical way to set some gsettings
    – Asalle
    Aug 12 '19 at 7:20
3

I configured those keys directly through Settings -> Devices -> Keyboard on Ubuntu 17.10. Under "System" section you have "Show the overview" which you can disable (by pressing backspace). And for "Show all applications" you can configure then Super.

4
  • 1
    Doesn't work on 18.04. I disabled that option but it still comes up when I hit the super key. Very very very annoying Jan 10 '19 at 21:01
  • Strange, works for me.
    – Mitar
    Jan 11 '19 at 1:13
  • I thought it might have to do with the fact that I'm using a wireless keyboard but the native one doesn't work either. It's a bit glitchy on a few settings Jan 12 '19 at 1:21
  • This doesn't work on Manjaro Gnome, i had to use gsettings manually instead, following unix.stackexchange.com/a/518458/54172 answer.
    – m3nda
    Aug 9 '19 at 0:18
3

I had the same problem on Ubuntu 17.10 and I had to install the following extension to make it work:

https://extensions.gnome.org/extension/1198/start-overlay-in-application-view/

Works like a charm! :)

1
2

For me, running Elementary OS, the below command worked:

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "['Super_L']"
1

On Ubuntu 18.04.4 LTS I've installed https://extensions.gnome.org/extension/1198/start-overlay-in-application-view/ and done

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "['Super_L']"
0

For GNOME 3.34.4 in Manjaro, try this

gsettings set org.gnome.shell.keybindings toggle-application-view "['Super_L']"
0

My custom shortcut key stopped working just now because of Tab key get stuck in my external keyboard. The key get stuck causes different combination keys and you may wonder why not working as expected.

So double check your keyboard for such case if keys not working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.