6

after a recent upgrade on my local Debian install Guake does not drop down by using F12

  Operating System: Debian GNU/Linux buster/sid
            Kernel: Linux 4.12.0-1-686-pae
      Architecture: x86
     Guake version: 0.8.8-1

once I started it manually I can call it with F12, but only on the virtual desktop where it was started, as soon as I change do a different desktop I can't call it with F12 anymore.

enter image description here

As you can see on the screenshot, I'm on the 2ond desktop and in the bottom left the guake symbol shows up. I can call the terminal by clicking there with the mouse. But F12 does not work.

If I start it from a terminal I get the following output:

(guake:3387): libglade-WARNING **: unknown attribute `swapped' for <signal>.
INFO:guake.guake_app:Logging configuration complete
/usr/lib/python2.7/dist-packages/guake/guake_app.py:865: GtkWarning: IA__gtk_window_set_type_hint: assertion '!gtk_widget_get_mapped (GTK_WIDGET (window))' failed
  self.window.set_type_hint(gtk.gdk.WINDOW_TYPE_HINT_DOCK)
/usr/lib/python2.7/dist-packages/guake/guake_app.py:866: GtkWarning: IA__gtk_window_set_type_hint: assertion '!gtk_widget_get_mapped (GTK_WIDGET (window))' failed
  self.window.set_type_hint(gtk.gdk.WINDOW_TYPE_HINT_NORMAL)
^CTraceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/dist-packages/guake/main.py", line 253, in <module>
    exec_main()
  File "/usr/lib/python2.7/dist-packages/guake/main.py", line 250, in exec_main
    gtk.main()
  • 1
    On debian stretch, I had similar problems with guake and Gnome-Wayland. It worked only if the mouse cursor was above an X/Xwayland window. With Gnome-X guake/F12 works fine. It is difficult to set keyboard shortcuts in Wayland. – mviereck Aug 26 '17 at 15:42
  • @mviereck wow, it seems to be the same here. I thought it did not work on the other desktops, but it was because there wasn't any window underneath. With firefox in the background it works on any desktop. With gedit it doesn't :-) – nath Aug 26 '17 at 16:47
11

I found a workaround for this issue on the official Guake github-page:

You have to go to the Gnome-Applications-Menu and click on the Keyboard Symbol.

This will list all the default Gnome-Keyboard-Shortcuts.

If you scroll down, click the + at the bottom of the page to add a new Shortcut:

Name: Guake
Command: guake -t
Shortcut: F12

In my case no reboot was needed.

The start of Guake by using this workaround is not very smooth, but usable...

from the guake man-page:

-t, --toggle-visibility  
      Toggle the visibility of guake
  • 1
    Note, that this becomes an issue also after update to Ubuntu 19.04, but your workaround works smoothly. – Jakuje Apr 30 at 20:14
  • 1
    Thank you! This happens to me on Gnome 3.34.1 on Wayland (Gnome on X.org worked fine). – meridius Oct 16 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.