0

I am running Debian Linux Stable (regularly updated) with LXDE desktop and it is otherwise running very well. I have HP Laserjet 1020 connected to it via USB. When I switch on the printer, I get following entries in 'desg' command output:

[ 5704.468021] usb 1-7: new high-speed USB device number 7 using ehci-pci
[ 5704.636216] usb 1-7: New USB device found, idVendor=03f0, idProduct=2b17
[ 5704.636221] usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 5704.636223] usb 1-7: Product: HP LaserJet 1020
[ 5704.636226] usb 1-7: Manufacturer: Hewlett-Packard
[ 5704.636228] usb 1-7: SerialNumber: JL1CQE6
[ 5704.639828] usblp 1-7:1.0: usblp0: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x03F0 pid 0x2B17
[ 5708.797352] usblp0: removed

(I think there may be a problem in last line)

In /dev folder, there is not entry with 'usb' in name:

root@debian-netinst:/dev# ls -ltrh | grep -i usb
root@debian-netinst:/dev#

There are some entries having 'lp':

root@debian-netinst:/dev# ls -ltrh | grep -i lp
crw-rw-r--  1 root lp       99,   0 Aug 24 10:42 parport0
crw-rw----  1 root lp        6,   0 Aug 24 10:42 lp0
root@debian-netinst:/dev# 

The printer is not shown in browser at site: http://localhost:631/

The printer is also not found when I run hp-setup -i as root and select usb option to search for printers.

Where is the problem and how can this be solved?

Edit: The command lsusb also finds the printer:

# lsusb
Bus 005 Device 005: ID 03f0:2b17 Hewlett-Packard LaserJet 1020

Edit: I could not solve the problem despite multiple attempts. Since this was an upgrade from Debian 8 (to 9) where I had installed and removed many programs (and some desktops also), I formatted the partition and did a fresh install of Debian-9. The printer works OK on this new installation.

  • You should show lsusb result if this command implemented in your distribution – dubis Aug 24 '17 at 8:14
  • lsusb finds the printer – rnso Aug 24 '17 at 9:47
  • You need to add a CUPS entry for the printer. This can be done via command line or via the web interface. – Faheem Mitha Aug 24 '17 at 11:59
  • Can you tell briefly how to do it or give a web link for that? – rnso Aug 24 '17 at 12:07
  • Printer is not found in localhost:631 – rnso Aug 24 '17 at 12:25
0

In the page http://localhost:631/admin/ you should have a button "add printer". after clicked on it, the browser will ask you your login and password of your end user (don't use root login). You will see a list . Your usb printer should be there

  • My printer does not appear in that list! That is what this question is all about. – rnso Aug 24 '17 at 14:08
  • So choice Local Printers: HP Printer (HPLIP) and click on continue then write usb://HP/LaserJet%1020 in the connection case of the browser page (source : foo2zjs.rkkda.com/cups/hp1020.html) – dubis Aug 24 '17 at 14:53
  • No HPLIP local printer choice is there. Only choices under Local printers are "Serial Port #1" and "LPT #1". Also, I have to be root else there is "permission denied" error. – rnso Aug 25 '17 at 5:07
  • your CUPs is not configured well, the end user should able to add printer. – dubis Aug 25 '17 at 5:48
  • Should I reinstall it? – rnso Aug 25 '17 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.