-2

I'm having an issue with Linux. The keyboard layout isn't correct. When I hit the forward slash key it displays a greater than symbol. Some of the other keys are also malfunctioning. I have an ASUS G51VX laptop and I'm using the built in keyboard. I'm using Mint Linux 18.2 Sonya with Cinnamon Desktop. When I look at the layout via the keyboard settings in Linux it's showing a key to the right of the " key doesn't exist on my actual keyboard (see pic below).

Edit: Here is the output from the setkbxmap -print:

xkb_keymap {
xkb_keycodes  { include "evdev+aliases(qwerty)"    };
xkb_types     { include "complete"    };
xkb_compat    { include "complete"    };
xkb_symbols   { include "pc+us+inet(evdev)+terminate(ctrl_alt_bksp)"    };
xkb_geometry  { include "pc(pc105)"    };
};

Here's a pic of the keyboard layout.
Picture of keyboard layout

Edit: Here is the output from dpkg:

dpkg: error processing package @BasileStarynkevitch keyboard-configuration (--configure): package keyboard-configuration is already installed and configured Errors were encountered while processing: keyboard-configuration

The error still persists when I try in virtual TTY.

I don't seem to have an Xorg.conf file.

Yes I've tried other desktop environments, they all have the same problem.

I tried dpkg-reconfigure keyboard-reconfiguration and got: dpkg-query: package 'keyboard-reconfiguration' is not installed and no information is available Use dpkg --info (= dpkg-deb --info) to examine archive files, and dpkg --contents (= dpkg-deb --contents) to list their contents. /usr/sbin/dpkg-reconfigure: keyboard-reconfiguration is not installed

So I tried sudo apt-get install debconf and it's already installed.

EDIT: For anyone interested, I finally found a solution that seems to work for every version of Linux I've tried:

https://defuse.ca/blog/linux-fix-pipe-character-on-asus-laptops.html

  • 2
    It is not a matter of kernel version or of distribution. It is a matter of keyboard configuration. Are you using a desktop environment? Which one (Gnome, KDE, ...)? – Basile Starynkevitch Aug 24 '17 at 4:10
  • 2
    Your question is unclear. Please edit your question to improve it: what keyboard do you have, what layout do you want, what keyboard layout did you configure, what distribution are you using, what desktop environment, what have you tried? – Basile Starynkevitch Aug 24 '17 at 4:33
  • 3
    In general: "trying different Linux versions" is not going to fix anything. But every distribution has a slightly different way of configuring the keyboard during the installation process. To verify what keyboard layout you have configured, please open a terminal, type setxkbmap -print, and edit your question with the output. Also please indicate your keyboard layout: Does it look like the picture labelled United States keyboard layout? If no, describe the differences. – dirkt Aug 24 '17 at 5:40
  • @left_luc_righty_tightly: Please edit your question and avoid commenting it. Comments are for others to ask you to clarify something. – Basile Starynkevitch Aug 24 '17 at 6:38
  • 1
    Question is closed, so I can't answer, but the problem is you specified a 105-key keyboard during installation. This keyboard does have the | key left of the " key according to the default geometry. If you had specified the correct number (104 or less), you would have got the correct layout, no matter on what distribution. Specifying the wrong number of keys does no harm, except that graphic produced for your keyboard layout is wrong (no matter in which distribution). – dirkt Aug 30 '17 at 15:03
1

The problem is you specified a 105-key keyboard during installation. This keyboard does have the | key left of the " key according to the default geometry. If you had specified the correct number (104 or less), you would have got the correct layout, no matter on what distribution. Specifying the wrong number of keys does no harm, except that graphic produced for your keyboard layout is wrong (no matter in which distribution)

  • I've not seen an option to specify 104 key during install. – lefty_lucy_righty_tighty Sep 21 '17 at 17:35
  • I am not familiar with the Mint installation process, but the number 105 must come from somewhere, and normally during the installation process, you get to choose your keyboard somewhere. You don't have to reinstall to change that, you can e.g. make your own xorg.conf to specify the keyboard layout you want. – dirkt Sep 22 '17 at 5:10
0

It would be easier for us to help you if you add to your post which language do you need and which keyboard layout you have right now.

Other refs can you see here and here.

Another thing to keep in mind, you need to configure your country (if you are not from there) usually that helps with all the GUI related languages.

Go to your system settings > language/localization/...

  • 1
    Furthermore, you should start your sentences with capital letters and avoid the unnecessary triple points. The content what you write is also for the googlers of the future, this is why the chatroom style is mainly discouraged. – peterh Aug 24 '17 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.