8

Our login screen requirements include a warning / disclaimer and a basic login, showing just a username and password field. Sadly, Gnome 3 seems to be ignoring the org.gnome.login-screen.disable-user-list checkbox presented by dconf-editor.

Can you disable the list of users displayed prior to login in Gnome 3 GDM?

| improve this question | | | | |
5

gdm3 loads its configuration in its own dconf database. This is separate apparently from the user dconf db that is accessible from the GUI with dconf-editor.

To edit the key value pairs which control the gdm settings and the login screen create a custom file in the /etc/dconf/db/gdm.d and add the custom entries there.

Do the following as the root user:

  1. touch /etc/dconf/db/gdm.d/01-custom-gdm-settings
  2. Add the following:

    [org/gnome/login-screen]

    disable-user-list=true

  3. Update the dconf database

    dconf update

  4. Restart gdm.

    systemctl restart gdm

    or

    /etc/init.d/gdm restart

More details on this can be found on the gnome sysadmin FAQ.

https://live.gnome.org/SysAdminGuide

| improve this answer | | | | |
1

This is what worked for me (Oracle Linux 6.5)
http://blog.toracat.org/2011/01/gnome-login-shows-all-valid-user-accounts-disable-it/

Edit the /etc/gconf/gconf.xml.defaults/%gconf-tree.xml file

Under this section

<entry name="disable_user_list" mtime="1400746800" type="schema" stype="bool" owner="gdm-simple-greeter" gettext_domain="gdm"
   <local_schema locale="C" short_desc="Do not show known users in the login window">
      <default type="bool" value="false"/>
      <longdesc>Set to true to disable showing known users in the login window.</longdesc>
   </local_schema>
</entry>

Change false to true and logout.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.