This question is an exact duplicate of:

I'm having trouble installing GRUB bootloader manually. I was attempting to install Kali Linux to dual boot with my already existing Windows 10 system. During the installation, it said it couldn't install GRUB, so I tried to manually install it from a Kali Live USB. However, whenever I run these commands in Terminal:

mount /dev/sda5 /mnt
mount --bind /dev /mnt/dev
mount --bind /dev/pts /mnt/dev/pts
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
chroot /mnt
grub-install /dev/sda

It says bash: grub-install: command not found. grub2-install also doesn't work. Trying update-grub says the same thing. GRUB was never installed, so how do I install it?

marked as duplicate by Rui F Ribeiro, andcoz, schily, slm Jul 24 '18 at 16:28

This question was marked as an exact duplicate of an existing question.


grub-install: command not found : make sure you mount /usr/sbin partition/drive to be able to execute this command.


Boot into kali live USB and run these commands:

mount /dev/sda5 /mnt
mount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
mount /dev/sda+ /mnt/boot/efi
mount -o remount,rw /dev/sda+ /mnt/boot/efi
mkdir /mnt/hostrun
mount --bind /run /mnt/hostrun
chroot /mnt
mkdir /run/lvm
mount --bind /hostrun/lvm /run/lvm
grub-install /dev/sda
umount /mnt/dev
umount /mnt/proc
umount /mnt/sys
umount /mnt/boot/efi
umount /mnt/hostrun
umount /mnt/run/lvm
umount /mnt

/dev/sda+ is your EFI partition which is most likely /dev/sda1.
Use fdisk -l to list all partitions.

Not the answer you're looking for? Browse other questions tagged or ask your own question.