1

Frist: I'm new to linux. I'm using debian 9.1.0 lxde 64 bits.

I gave up trying to change the resolution when I got black screen at the login screen, just the terminal mode (Ctrl+Alt+F1) works. I tried the commom cvt -> xrandr --newmode -> xrandr --addmode -> xrandr output I get an error at the addmode step, and tried with gft too, but the same. also tried to edit the xorg.conf file, it was when I got this issue. I actually have access to my ext4 partition throuth windows 10 (using ExtFS). My driver version is 384.69, my gpu is gtx 750ti, my monitor is XP911AW. I got this data from it's EDID (all from the same file, at one run):

DumpEDID v1.06
Copyright (c) 2006 - 2017 Nir Sofer
Web site: http://www.nirsoft.net

Active                   : No
Registry Key             : DISPLAY\PEB038F\1&8713bca&0&UID0
Monitor Name             : XP911AW
Serial Number            : 0708500665431
Manufacture Week         : 37 / 2007
ManufacturerID           : 41536 (0xA240)
ProductID                : 911 (0x038F)
Serial Number (Numeric)  : 16843009 (0x01010101)
EDID Version             : 1.3
Display Gamma            : 2.20
Vertical Frequency       : 56 - 76 Hz
Horizontal Frequency     : 30 - 81 KHz
Maximum Image Size       : 41 X 26 cm (19.1 Inch)
Maximum Resolution       : 1440 X 900
Support Standby Mode     : Yes
Support Suspend Mode     : Yes
Support Low-Power Mode   : Yes
Support Default GTF      : No
Digital                  : No
Supported Display Modes  :
 720 X  400  70 Hz
 640 X  480  60 Hz
 640 X  480  72 Hz
 640 X  480  75 Hz
 800 X  600  56 Hz
 800 X  600  60 Hz
 800 X  600  72 Hz
 800 X  600  75 Hz
1024 X  768  60 Hz
1024 X  768  70 Hz
1024 X  768  75 Hz
1280 X  960  60 Hz
1280 X  960  75 Hz
1440 X  900  60 Hz
1440 X  900  75 Hz
1280 X 1024  60 Hz
1280 X 1024  75 Hz


Active                   : No
Registry Key             : DISPLAY\PEB038F\4&2c0f5421&0&UID16843008
Monitor Name             : XP911AW
Serial Number            : 0708500665431
Manufacture Week         : 37 / 2007
ManufacturerID           : 41536 (0xA240)
ProductID                : 911 (0x038F)
Serial Number (Numeric)  : 16843009 (0x01010101)
EDID Version             : 1.3
Display Gamma            : 2.20
Vertical Frequency       : 56 - 76 Hz
Horizontal Frequency     : 30 - 81 KHz
Maximum Image Size       : 41 X 26 cm (19.1 Inch)
Maximum Resolution       : 1440 X 900
Support Standby Mode     : Yes
Support Suspend Mode     : Yes
Support Low-Power Mode   : Yes
Support Default GTF      : No
Digital                  : No
Supported Display Modes  :
 720 X  400  70 Hz
 640 X  480  60 Hz
 640 X  480  72 Hz
 640 X  480  75 Hz
 800 X  600  56 Hz
 800 X  600  60 Hz
 800 X  600  72 Hz
 800 X  600  75 Hz
1024 X  768  60 Hz
1024 X  768  70 Hz
1024 X  768  75 Hz
1280 X  960  60 Hz
1280 X  960  75 Hz
1440 X  900  60 Hz
1440 X  900  75 Hz
1280 X 1024  60 Hz
1280 X 1024  75 Hz

Just a little off-topic, do you know if this driver (downloaded from geforce.com, which is a .run file) includes cuda too?

EDIT: I tried to edit the xorg.conf file from windows, no sucess, and now the screen don't become black anymore, but don't start the graphical interface at all. I still can use the CTRL+Alt+F1

  • Попробуй install nvidia-current , но сначала удали то что поставил. Незн точно какой в дебе пакетный менеджер. Для бубунты такая комманда apt install nvidia-current – root_x Povierennyy Aug 22 '17 at 19:59
  • try install nvidia-current from standart reps. – root_x Povierennyy Aug 22 '17 at 20:01
  • Do I have to uninstall the driver alredy installed? The problem looks like a xorg.conf problem, but I changed this config to try change the resolution to 1440x900@75hz. What's the difference between the official driver and the one from apt install nvidia-current? Does this at least resets the current config files? Does cuda works with this driver? – geekformoney Aug 23 '17 at 2:24
  • the apt install nvidia-current returned something like "no candidates available to install". – geekformoney Aug 23 '17 at 14:38
1

Again, I could solve my problem. Here is how:

at the login screen, I entered in the terminal mode and typed:

  1. cvt 1440 900 75 (my wanted resolutions and refresh rate, and copied the modeline string)
  2. su
  3. nano /etc/X11/xorg.conf Here I updated my refresh rates and added the entire modeline string.

    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 76.0
        Modeline "1440x900_75.00" 136.75 1440 1536 1688 1936 900 903 909 942 -hsync +vsync
        Option         "DPMS"
    EndSection
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.