5

I'm looking for a way to get mutt to properly display Unicode characters when selecting and saving attachments.

I will often see a line like this in mutt

 A 6 =?UTF-8?B?MS0yIEZhbiAyIFBhcmFtZXRlcnMg6Y      [applica/pdf, base64, 56K]

while the actual title of the document is

1-2 Fan 2 Parameters 选型参数表_II.pdf

Needless to say, when there are more than a few of these documents attached to an email, it's quite difficult to tell them apart and save them efficiently if need be.

I don't have an issue viewing Unicode characters in subject lines or in message bodies.

The charset for my mutt is "UTF-8". I'm using the apt-get version of mutt (1.5.24) on Lubuntu. Mutt is pointed at a Gsuite account, if that makes a difference.

1
  • 1
    I'm using 1.5.21 and attachment names with UTF-8 encoding are rendered correctly. No special settings.
    – Juancho
    Commented Aug 22, 2017 at 18:26

1 Answer 1

8

Please see the explanations of rfc2047_parameters in manual for muttrc for details.

Simply add,

set rfc2047_parameters = yes

to your .muttrc

2
  • Thanks! The weird part is that the manual says this is on by default, and somehow I permanently turned it off without using my .muttrc.
    – aepksbuck
    Commented Aug 23, 2017 at 14:55
  • my man muttrc says that it is off by default
    – mrajner
    Commented Aug 23, 2017 at 16:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .