1

I have been struggling for the past couple of days attempting to hook up my 1920x1080 external monitor to my 3200x1800 laptop.

When I run xrandr, it outputs:

Screen 0: minimum 320 x 200, current 5120 x 1800, maximum 8192 x 8192
eDP-1 connected 3200x1800+1920+0 (normal left inverted right x axis y axis) 294mm x 165mm
   3200x1800     59.98*+  47.99  
   2048x1536     60.00  
   1920x1440     60.00  
   1856x1392     60.01  
   1792x1344     60.01  
   1920x1200     59.95  
   1920x1080     59.93  
   1600x1200     60.00  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   800x512       60.17  
   700x525       59.98  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
DP-1 connected primary 1920x1080+0+720 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00 +  50.00    59.94  
   1920x1080i    60.00*   50.00    59.94  
   1600x1200     60.00  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

So, I figured if I run, xrandr --output DP-1 --mode 1920x1080, then the display would show on the external monitor... I was wrong: the monitor claimed to have no signal. I followed this comment which allowed the monitor to detect the HDMI signal, but I could only use a resolution lower than 1024x768. I played around a bit more, and the monitor detected 1920x1080i as well, but the borders around the screen were cutoff.

I did some research and figured out about something called overscan and used xrandr --output DP-1 --set underscan on, but that caused the following output:

X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  11 (RRQueryOutputProperty)
  Serial number of failed request:  38
  Current serial number in output stream:  38

I also tried to add a new mode via xrandr and cvt and also tried changing the display settings via the settings panel in Ubuntu. There does not seem to be a problem with the monitor because it works fine when I boot Windows 10.

Is there anything else I could try?

Machine: Dell XPS 13 9350 (no hardware changes)

OS: Ubuntu 16.04 LTS

External Monitor: Dell S2415H

  • errr... does xrandr --output DP-1 --auto work? That first command you tried should work, but maybe it didn't actually enable the display. A computer monitor really shouldn't have overscan issues, BTW. – derobert Aug 22 '17 at 14:48
  • If i do xrandr --output DP-1 --auto, the monitor doesn't detect any signal even though the computer detects the monitor. – ljeabmreosn Aug 22 '17 at 23:30
0

Install graphics drivers.

Select kde-plasma-desktop, reboot, load KDE, see what can do, deselecting it if can't do and you want to reclaim back the used device space.

0

A year later, and I have somehow managed to fix the problem, though I don't know exactly how. It is important to note that my monitor does not have any settings for disabling overscan or any related.

Graphics Drivers

I thought I needed to update my graphics drivers, so I ran the following commands:

sudo apt-get update
sudo apt-get install xserver-xorg-core xserver-xorg-video-intel

Then, I decided to reboot the machine with:

shutdown -r now

But, when I tried to login, the screen froze.

Recovery Mode

I went into recovery mode from my bootloader and went to tty1 (by pressing crtl + alt + f1), logged in, and and the following commands:

sudo apt-get purge xorg lightdm
sudo apt-get autoremove
sudo apt-get install xorg lightdm

So, if I understand these commands correctly, I essentially removed all existing configurations of xorg and lightdm from my machine and reinstalled the packages. During the installation process, I decided not to use lightdm as my display manager but rather gdm3.

I then rebooted the machine (not in recovery), and plugging in my monitor worked as expected - no cutoff display borders. I am not quite sure what it was exactly that caused this behavior, but I wanted to document my steps to fixing this problem. It could just be as simple as changing the default display manager from lightdm to gdm3.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.