0

When i trying to add or update repository, it show me error: Empty destination in URI:hd:///device=/dev/disk/byid/scsi1SanDisk_Cruzer_Blade_4C532000010320108422-part2 , also i have the same error when try to open software manager.

Error screenshot: enter image description here

knowing that scsi1SanDisk_Cruzer_Blade is the bootable usb which i used to install OpenSuse 42.2 leap KDE Plasma version 5.8.6 .

Thank you for help.

3
  • 1
    Go to software repositories in Yast and delete that entry.
    – n8te
    Aug 22, 2017 at 11:15
  • It's done. Thank you, but why or how this repository added? Aug 22, 2017 at 11:19
  • It's happened to me before as well. It gets put there during the installation. I can't say for sure why
    – n8te
    Aug 22, 2017 at 11:20

2 Answers 2

0

This same behavior described by Mohamed Maher became an issue in openSUSE Tumbleweed early in 2019.

In Tumbleweed, use YaST to display the repositories. Find the repository named: openSUSE-20190525-0 except the date in your repository name will be the YYYYMMDD of your release. The URL will vary depending on the install source but will likely begin with: hd:/?device=

In the lower part of your YaST window, deselect (uncheck) the two Properties checkboxes for "Enabled" and "Automatically Refresh" then select the "OK" command button, and the problem will be solved in Tumbleweed.

0

The answer given didn't work for me. So I just left the above mentioned repositories enabled and auto refresh. Then I simply just plugged in my Sandisk Cruzer flash drive with the installer still installed in it, and voila it worked like a charm. This might not be the most elegant of solutions but it worked for me. I just love Tumbleweed opensuse! But then if I wanted easy I would use nobuntu LOL!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .