-2

i have gnome-tweak tool running on a install of Debian 8 with gdm3 installed, how do i allow this application to run with full permissions? When i run "sudo gnome-tweak-tool" the program runs as expected, but when i try to run some programs from the applications menu or just using the app name without sudo from terminal, there are problems. With gnome-tweak-tool it runs but it's not possible to change anything, and it opens with a theme different to the system theme. I don't have this problem on Ubuntu gnome, could someone please explain why that would be, what am i missing, how do i fix it without adding sudo or gksu to the exec line of every .desktop file?

This is what i expect to happen:

enter image description here

Here's what's actually happening without running with sudo from terminal:

enter image description here

0

There was a problem with gnome install.

I ran these commands in the terminal;

sudo apt-get --reinstall install gdm3 -y
sudo apt-get --reinstall install gnome -y
sudo apt-get --reinstall install gnome-shell -y 

Now gnome-tweak-tool works fine when launched from the applications menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.