My Mint crashed twice yesterday. Googling for frozen system with flashing caps and scroll-lock LEDs made me believe it was a hardware problem. I carefully cleaned everything, and the hardware seems to work ok again - I had no more crashes.
Today I tried downloading a file and I got a pop-up saying the disk is write-protected. Also, apt-get update returns me a lot of errors about "read-only filesystem".
I tried this and this. Here are the outputs:

# blockdev -v --setrw /dev/sdb set read-write succeeded.

# mount / -o remount,rw mount: cannot remount /dev/sdb6 read-write, is write-protected

# hdparm -r 0 /dev/sdb /dev/sdb: setting readonly to 0 (off) readonly = 0 (off)

# mount / -o remount,rw mount: cannot remount /dev/sdb6 read-write, is write-protected

I tried both blockdev and hdparm using /dev/sdb and /dev/sdb6, and running # echo $? after each of them always returns 0, indicating success, but nothing seems to work.

Also, my /home folder is at /dev/sdb7 and I can write files normally to it.

Here is the output for # fdisk -l
Disk /dev/sdb: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0005683d

Device Boot Start End Sectors Size Id Type
/dev/sdb1 * 976963584 1953523711 976560128 465,7G 7 HPFS/NTFS/exFAT
/dev/sdb2 2046 976962885 976960840 465,9G 5 Extended
/dev/sdb5 2048 2000895 1998848 976M 82 Linux swap / Solaris
/dev/sdb6 2002944 41062399 39059456 18,6G 83 Linux
/dev/sdb7 41064448 976962885 935898438 446,3G 83 Linux

The /dev/sdb1 is a NTFS partition I made to be accessible from Windows, which is at /dev/sda.

Any ideas on how I could fix this? Thanks for your patience.

  • 2
    Backup it and buy a new disk. – Rui F Ribeiro Aug 21 '17 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.