3

I powered on my laptop running Debian kernel 3.3.0. After the boot process starts the X server and KDE, my keyboard and mouse do not function. Keyboard input works when I use the Recovery Console, and both the keyboard and mouse work when I boot into Windows. I've tried booting into Recovery Mode, and then into KDE, but it still doesn't show that I'm typing or that I'm moving the mouse.

I have also tried booting the previous 3.2.0.2 kernel, but both keyboard and mouse fail to receive input and do not respond.

EDIT: I logged into the recovery mode, and was able to get /var/log/Xorg.0.log. /etc/X11/xorg.conf did not exist.

/var/log/Xorg.0.log: http://pastebin.ca/2149488

EDIT 2: I tested to see if an external wired USB mouse and keyboard would work, but neither worked. I'm guessing it's an input problem with the X server, rather than just my keyboard and mouse inside the laptop.

EDIT 3: I tested two things: to see if the mouse is working at all in linux, and if other display managers would work. I ran cat /dev/input/mouse0 and ran my finger on the touchpad, and it displayed random stuff, so I can verify that the touchpad works.

I installed and tested both gnome, gdm3, and lxde, startlxde, but neither worked. Both did not let me move my mouse and did not let me type.

EDIT 4: Still trying... I purged xorg and xserver-xorg using apt-get purge xorg xserver-xorg and ran apt-get autoremove to get rid of the various xserver installs. Then I reinstalled both xorg and xserver-xorg and ran /etc/init.d/kdm start but the same problem happened.

So I just tried to start a simple X server display after restarting the computer. I went into maintenance mode, and ran xinit. When the terminal popped up, I could not type and had to force the computer to reboot. So I am guessing it is some configuration for the X server. I don't have Xorg.conf... are there any other configurations for X server?

EDIT 5: I got something working! I ran startx and then plugged in an external mouse, and I finally got the mouse cursor to move around. However, I could not get the keyboard to type or the touchpad on the laptop to actually do anything. So it looks like it just doesn't recognize both my keyboard and mouse on the laptop itself. Is there a way to configure the X server to accept input from more inputs, such as the keyboard and internal mouse?

  • 2
    Can you ssh (or reboot into rescue mode) and recover some logs? /var/log/Xorg.0.log might be interesting. – sr_ May 16 '12 at 14:29
  • Yes, please post the log like sr_ said, plus /etc/X11/xorg.conf, if you have one. – Kevin May 16 '12 at 15:41
2

Solution to issue: Not all input packages installed for xserver.

If you are running into this issue of mouse and keyboard not working, make sure you have all the xserver packages installed. Sometimes this issue happens when not all input packages are installed.

To fix this issue quickly, install the metapackage xorg:

apt install xorg

This meta package makes sure that all the required packages are installed for a fully functioning xserver system. This is current for Debian Stretch (as of this writing) This is a very old post, but I came across it with the same problem and this solution worked for me.

  • more precisely this package: xserver-xorg-input-all – dasj19 Dec 30 '18 at 18:07
0

Unfortunately I could not find a solution to fix the X server and allow me to use the mouse. I downloaded a live CD of Debian KDE and my mouse and keyboard worked, so it was a configuration that got messed up.

I ultimately reinstalled the core operating system. I had my data (/home,/usr, etc.) in separate partitions so I just had to reinstall /.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.