2

I am struggling with making my Bose Quiet Comfort 35 headset work on my XPS 15 9550 running Arch Linux. The headset works on my other computer (also running Arch), but I just can't figure out how to make it work on this laptop...

I first installed pulseaudio-bluetooth, bluez, bluez-libs and bluez-utils, then enabled and started the bluetooth service, without errors. I then set "ControllerMode=bredr" in "/etc/bluetooth/main.conf", restarted bluetooth and attempted to pair using blutoothctl. This failed, and led me to believe some firmware was missing. Installing bluez-firmware changed nothing, so I downloaded and installed the firmware for my card: aur.archlinux.org/bcm20702a1-firmware.

The headset pairs and connects now, but the connection is always and immediately dropped:

Device 04:52:C7:77:81:E3 Bose QuietComfort 35
[CHG] Device 04:52:C7:77:81:E3 Connected: yes
[CHG] Device 04:52:C7:77:81:E3 Connected: no

The same thing happens when using "blueman-applet", with the following error:

Connection Failed: blueman.bluez.errors.DBusFailedError: Input/output error...

In journalctl the following error appears:

Aug 20 21:38:18 duty bluetoothd[317]: Endpoint replied with an error: org.freedesktop.DBus.Error.AccessDenied

Running "blueman-applet" as sudo reports the following error:

dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NotSupported: Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUS_ADDRESS instead

Running "bluetoothctl" as sudo yields the connection followed by immediate disconnection result.

I've tried following suggestions from similar threads and mess around with "/etc/bluetooth/audio.conf", but to no effect.

I'm guessing it's a problem related to "pulseaudio-bluetooth", but am unable to debug any further, as I don't know what else can be done, nor where to look for more detailed error reports.

Might be worth noting that running "sudo pactl load-module module-bluetooth-discover" yields the following errors:

Connection failure: Connection refused
pa_context_connect() failed: Connection refused

Any help is much appreciated...

0

You might be missing notification daemons.

I believe this to be the case because blueman seems to be relying on system notifications instead of a regular dialog box for pairing devices. And you don't mention seeing any notifications.

See this question, where I luckily had one, but its notifications had no Confirm/Deny buttons.

Edit: another answer seems to be more complete (showing you the mechanism of Unity notifications).

In short: install notification-daemon (from Gnome) or some other notification daemon, then make sure it starts on startup, then restart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.