2

After upgrading my Jessie machines to Stretch, they no longer cleanly reboot, even if using the Jessie kernel. I tried reboot=BIOS, ACPI, PCI, even force=ACPI, but none work. The reboot hangs on:

[ OK ] Removed slice system-postfix.slice

but it's still alive - I can keep pressing Ctrl+Alt+Delete and get:

[447.012345] systemd-shutdow: 35 output lines suppresed due to ratelimiting
[447.012346] systemd-shutdown[1]: Sending SIGTERM to remaining processes...
[447.012347] systemd-journal[175]: Received SIGTERM from PID 1 (systemd-shutdow).

Then it freezes for about 90 seconds (suppose DefaultTimeout from system.conf) and then finally reboots. This happens on both systems I've upgraded to Jessie.

I also tried swapoff -a, to no effect.

  • 1
    I do agree this is frustrating. On one hand you did your best to provide us with all you have. On the other hand, you must admit that there is so little information that we can not really help you. Some message here from those who decided to close would have been welcome, though. Back to your question, have a look to this one on AskUbuntu. Did you install all the firmware packages that pertain to your platform? – xhienne Aug 21 '17 at 21:58
  • I'm not sure what firmware should I install/reinstall -there's no wifi card at all - I'd love to present some logs which could lead to solution, but I don't know what - I don't see anything strange in syslog nor messages. I can turn on debugging - but how? – Tomasz Brzezina Aug 22 '17 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.