0

I am using tmux 2.1 on Ubuntu 16.04.  I would like to have the background have some transparency.  A lot of times I need to reference something at the same time I use the terminal. 

I have looked at http://man.openbsd.org/OpenBSD-current/man1/tmux.1  and Reset background to transparent with tmux?  this seemed to suggest that setting bg=default would do it but it gives me the default solid purple. I tried using a hex code of #80FFFFFF which tmux rejected.

edit: The old post noted above does not explain how to set the transparency in tmux- at least not to me :(

Help greatly appreciated.

2
  • @ThomasDickey I did look at that post. He does say setting bg to default resulted in a transparent status bar but when I tried bg=default it did not work for me. Also, he is using tmux-powerline. I was hoping to get a more direct answer to my sito. One of those little things that would make my life much easier.
    – RGB
    Commented Aug 19, 2017 at 14:47
  • Current tmux is >2.5 (May 2017), and the documentation with the obscure clues doesn't apply to 2.1 (that was October 2015). Commented Aug 19, 2017 at 14:47

1 Answer 1

0

The transparency preferences is not part from tmux, you need to change your profile preferences from your terminal

Edit > Profile preferences > Colors

uncheck Use transparency from system theme and

check Use transparent background

configure the level of opacity and that's it

6
  • Which terminal emulator are you referring to? The instructions look very specific.
    – chepner
    Commented Aug 19, 2017 at 18:05
  • I'm refering to the terminal application that ubuntu has as default because @RGB said that "A lot of times I need to reference something at the same time I use the terminal." Seems to be a terminal problem rather than tmux Commented Aug 19, 2017 at 18:08
  • The OP didn't really mention which terminal emulator they are using (although it is perhaps a valid assumption the OP is using the one you reference). It is definitely a terminal issue, rather than something tmux can do itself.
    – chepner
    Commented Aug 19, 2017 at 18:12
  • yep :) my assumption based on the distro, configs, and desires from the user... I hope to be right with this, but @RGB will have the last word :) Commented Aug 19, 2017 at 18:15
  • @ChristopherDíazRiveros yes thank you, that is what I was looking for- somehow I thought it was a tmux issue. Also, although I sain 'when I use terminal' I really meant tmux but this answer solved it.
    – RGB
    Commented Aug 20, 2017 at 0:51

Not the answer you're looking for? Browse other questions tagged .