4

Getting the following error:

Unable to complete install: 'unsupported configuration: CPU mode 'custom'
for x86_64 kvm domain on x86_64 host is not supported by hypervisor'

Im using arch linux x64, Intel Core i7-6700K @ 8x 4.2GHz, x86_64 Linux 4.12.8-1-ARCH

Im selecting skylake-client under CPU options during installation but that is what I get. Can some one help? Maybe I'm missing something simple that I am not seeing.

2

Did not want to leave this hanging. I was able to solve the problem by selecting [x] copy host cpu configuration from the settings virt-manager. Im not sure why this works vs manually specifying the cpu architecture.

0

x86_64 guest not supported by your hypervisor. Seems like you have not enabled Virtualization Technology (vtx/vtd) in your bios. Run this command to check it on your linux box

grep -E '(vmx|svm)' /proc/cpuinfo

  • 3
    its enabled: $ grep -E '(vmx|svm)' /proc/cpuinfo flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault epb intel_pt tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle – jes516 Aug 21 '17 at 1:59
0

Ok if you get access restriction error, do not use the first "connexion" (qemu:///system) but create a new one called qemu:///session

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.