0

I have a symlink like this:

$ /path/a/ftplandingpath -> /mnt/volume

Then, when I login with my ftp client, it goes to /mnt/folder instead of /path/a/ftplandingpath:

client> ftp SERVER
client> username: userftp
client> password: ***
ftp> pwd
ftp> /mnt/volume < this is the sad thing :(

I need my path goes to the landing path I assigned instead the original path that the symlink is pointing to.

In Solaris it worked fine but I cannot figure it out what is the difference between both systems.

You would be asking: "Why this should be like this and not with an straight path?" It is required in order to avoid the modification of lots of code.

Thank you all!

1

Instead of a symlink you could use a bind mount. (mount -o bind /srcpath /destpath). That'll foil software that will look up symlinks.

  • I will give a try and also will keep you updated if it works. Let's see. Thank you jsbillingsa – user3143416 Aug 20 '17 at 13:01
  • It did not work jsbillings, the path still goes to the original when I connect through ftp client. Any other option you know? – user3143416 Aug 24 '17 at 20:56
  • That's perplexing. Are you certain it is actually set as the location of the FTP user's home directory? – jsbillings Aug 25 '17 at 2:36
  • Yes in fact is something we are trying to figure it out why is it doing it in that way, it is kind of either an error or a bug in red hat 7. We are getting mad with this. – user3143416 Aug 27 '17 at 0:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.