1

I am currently using Linux Mint 18.2, Cinnamon 3.4.6, and Nemo 3.4.6 aswell.

I seem to be having an issue with Nemo. My places (those bookmarks that are like Music, Pictures, Documents, etc) are now in my bookmarks section and without icons. All they show is a folder icon and the symbolic link icon next to them (since I have my Music, Pictures, Documents and such all located on an external hdd). This is making it difficult to determine which is which since I usually determine the folder by what icon it has first. It doesn't help that the places bookmarks are not in their original positions. This has happened twice already. I can't remember exactly how I was able to fix the issue before, but I remember there was a bookmarks config file with bookmarks and places separated. I don't remember where it is located but it fixed the problem.

So, that is what I am asking. Where the bookmarks config file for nemo is. I am sure it will fix this same issue for a second time. If anybody has any alternative way to fix this issue, I am all ears. Maybe possibly resetting all the settings of nemo? I don't know.

  • Can you use the menu option Bookmarks -> Edit Bookmarks to fix this? – Tigger Aug 18 '17 at 23:18
  • No, as it doesn't appear to have an option. Unless there is something I don't know about. All the folders are named correctly, and just show up as regular bookmarks. – Vencorr Aug 19 '17 at 0:09
2

Bookmarks are loaded from /home/<username>/.config/gtk-3.0/bookmarks. (Using strace to see what files are accessed. Also adding bookmark adds to this file, and adding lines to this file adds bookmarks.) This file looks like this:

file:///home/<username>/Documents Documents
file:///home/<username>/Music Music
file:///home/<username>/Pictures Pictures
file:///home/<username>/Videos Videos
file:///home/<username>/Downloads Downloads

Images used are located in /usr/share/icons/Mint-X/places/16. (Path will vary depending on your theme.)

0

I had that problem myself. I've solved that with Links. To make it work follow those steps:

  1. Move any data in the original folders to the desired new locations.

  2. Delete the folders from your Home folder.

  3. Select the folders in the desired new location and drag them to the home location while pressing the Alt key. Make sure the folders names are identical to the original names in your home folder.

  4. A menu will pop-up asking what action to take. Select "Link Here".

  5. Add the bookmarks of the linked folders to the bookmarks pane.

You will see the folders with their original emblems (icons) in your bookmarks pane, and as a side effect, all the system actions will point now to your new locations, so there is no need to change any of the default locations for Downloads, Documents, etc...

Hope that this is useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.