32

How to exit fullscreen mode in vinagre VNC client?

I have not found any key combination to do this.

7 Answers 7

16

You also have to enable keyboard shortcuts in the Menu (check view->keyboard shortcuts). Then F11 is you key of choice (for me at least in version 3.22.0, you can check the shortcut key once it's enabled in View->Fullscreen)

This is where I found the suggestion: https://bugs.launchpad.net/ubuntu/+source/vinagre/+bug/1547770

3
  • spot on, excellent recipe. worked for my ubuntu 16.04.4 instance running xfce desktop & vnc4server. local machine running 17.04 and vinagre with putty ssh tunneling. UPVOTED! : )
    – tony gil
    May 8, 2018 at 10:55
  • 4
    This design is terrible! So View > Keyboard shortcuts actually enables keyboard shortcuts. One downside is that several other shortcuts are also enabled, and start conflicting with normal usage, e.g. if I try to Ctrl + W my browser it closes the connection instead. Tested on ubuntu 18.04 host, vinagre 3.22.0-5. Jul 1, 2018 at 9:38
  • 3
    thanks. what an idiotic design, truly. when you are stuck, try to move mouse top left corner, use alt-tab to get "out" of vinagre. Use killall vinagre from a terminal. restart it, make sure keyboard shortcuts is enabled. Now all sorts of other keyboard short cuts are not available to the remote desktop. "brilliant".
    – 0__
    Feb 4, 2019 at 19:34
7

For me the following worked in Ubuntu 16.04: move mouse pointer to the top center of the screen. A hidden toolbar should've appeared, but it doesn't. It turns out, it is still there, it's just invisible: mouse pointer shape changes in that region, when it touches the top edge of the screen. So I click where I expect the "leave full screen" button be, in the left part of the invisible toolbar, and it leaves fullscreen mode. Position of the invisible toolbar can be probed by watching mouse pointer shape changes.

2
  • Wow, this worked exactly in F31! On my set up, "fullscreen" actually expanded across both my primary (laptop) screen plus one of my additional monitors. I pushed the mouse pointer up to the top, slid it over to where the two screens separate (the overall center) and poof, a different mouse pointer. I then went down ever so much and a little pop-up said "Leave fullscreen" so I clicked. Voila!
    – mike65535
    Apr 10, 2020 at 17:26
  • Thanks Alexey! I went in full screen without enabling keyboard shortcuts and couldn't figure out how to exit it. Found the invisible area where my mouse cursor changed. No tooltips for me, but I just floated the cursor across it and spam clicked until something, anything, happened. Eventually I chanced upon the close connection button. Good enough to get back to the GUI and enable keyboard shortcuts. You saved my bacon.
    – rojo
    Aug 9, 2020 at 2:46
4

On Debian Stretch the key is F11 (See Top menus)

1
  • 3
    on ubuntu as well, but you may have to enable KEYBOARD SHORTCUTS - UPVOTED! : )
    – tony gil
    May 8, 2018 at 10:55
3

Only way that works is to bring up an xterm of you choice and kill it.

The hidden center toolbar remains hidden on the systems I've checked.

Would be helpful to add keyboard shortcut for this purpose.

2
  • I also didn't see any hidden center toolbar, although I'm used to them from e.g. fullscreen VMs, and tried to find one in Vinrage ( + tried pointing the mouse in the corners too). — It'd be nice with a right click mouse popup item: "Exit fullscreen". — I think many people don't know how to start an xterm, when their whole screen is "taken"; then for them the solution is to reboot their computer, to exit Vinagre fullscreen?
    – KajMagnus
    Feb 11, 2020 at 5:46
  • @KajMagnus What is an xterm and how do I start one?
    – Moberg
    Jan 17 at 16:09
3

F10 key was the solution.  I was stuck on the fullscreen mode and by pressing F10 I was able to get back on my main screen.

1

From the official website

While in fullscreen mode, move the mouse to the top-center of the screen to display a hidden toolbar, which has Leave Fullscreen, Disconnect and other buttons.

4
0

There should be a menu showing up when you bring the mouse at middle the top of the screen.

You can also use the Super + Esc key combination to send the next keystroke to the host (this is mentioned in the popup when you start a fullscreen session), so you can then use Alt + Tab or Super again to switch to another app or terminate the session.

Super is the Win key (logo) on Microsoft™ keyboards.

Note: For me the top menu didn't seem to work at all; I noticed later that the tooltips would show up as I hovered around where the menu buttons should be, so the menu is there but not visible and the tooltips might be sufficient to find the right button. None of the other answers I've seen mentioned the appropriate default key combination for my standard Remote Desktop app on Debian Buster.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .