3

I'm using Fedora Core 26 and I have problems with some icons in some programs. I'm using an old Nvidia GeForce GTS 8800 and the nouveau drivers. Seems to only affect toolbar icons of GTK programs. The Chromium I'm using to post this is unaffected, as is the GNOME Desktop.

On the same machine. I'm also using Arch and Ubuntu 17.04 (both w/ proprietary drivers) and the glitch only appears in Fedora Core, so perhaps this is a gtk/nouveau bug.

Audacious, main window Audacious toolbar

Gparted, main window Gparted toolbar

GIMP floating tool window GIMP toolbar

Is there a fix for this? I have tried googling but I can't find anything relevant.

*** Edit: I get the same glitch when installing gparted to the live USB environment, so I'm now strongly leaning towards a gtk/nouveaue issue, possibly only when triggered by older NVidia h/w. Will report back from installed Fedora Core ASAP.

*** Edit: Same bug when booting into freshly installed Fedora Core 26. More evidence towards the gtk/nouveau + older NVidia h/w hypothesis.

  • 1
    What's the question that you want us to answer? – roaima Aug 18 '17 at 14:41
  • Are you using Wayland? Does it happen in X11? – mattdm Aug 18 '17 at 22:42
  • @mattdm Yes, this is bog standard Fedora Core 26 so I'm on Wayland. I tried logging in with Gnome on X11 and I still have the glitch. – Emanuel Landeholm Aug 19 '17 at 5:42
2

Try changing themes in the Appearance control panel. You may have a corrupted or nonstandard icon set.

| improve this answer | |
  • I tried that. I have also played around with gnome-tweak-tool to no avail. Honestly, this might just be a botched install. If I don't get any good suggestions soon, I'm just going to try reinstalling. – Emanuel Landeholm Aug 18 '17 at 19:01
  • 1
    @EmanuelLandeholm to check for corrupted image files from the fedora packages, you can use rpm --verify --all. That's how I found mysterious errors which were caused by a corrupted SSD :). bugzilla.redhat.com/show_bug.cgi?id=1409874 – sourcejedi Aug 19 '17 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.