1

So I'm working on a friend's computer to install Linux Mint 18.2 onto it since his Windows broke after the Creator Update. He wasn't able to install it himself for some reason, however when I first tried the Live USB on the system, it booted right into the Live USB and I was able to complete an install to his SSD. After the install, we attempted to reboot into the installed partition, however it goes to the GRUB menu, and once we select the installation for Linux Mint it just goes to a black screen with nothing on it, we've waited over 10 minutes with no changes to the screen. We then tried the Live USB again, multiple times and gives us the same thing as booting into the partition, a blinking underscore in the corner for a second and then just a black screen, then the screen goes to sleep. Systems specs are an FX-8350 and a Radeon R9 280X, no onboard video

What have we tried?

We've tried changing the boot parameters to have nomodeset xforcevesa instead of "quiet splash", this works about 10% of the time to get it to boot into Mint from the installed partition. The other 80% it goes to the command line output for booting into everything and reaches Switching to clocksource: tsc (or something similar) and then just freezes and doesn't go anywhere. The other 10% it just hangs in the middle of boot sequence. If we keep quiet splash and put in the nomodeset xforcevesa we receive an ERROR no UMS support in radeon module

We also tried just a nomodeset, this doesn't seem to have much affect, maybe 1 % or less of the time it loads into the OS.

We tried a live USB of Ubuntu 16.04 LTS, I have not been able to boot into it at all, even with the various parameter changes. We've tried using noacpi and nolacpi and acpi options in the Ubuntu Live USB to no avail, gives us I believe the ERROR No UMS Support in radeon module errors.

We've tried a live USB of Linux Mint 17.3 since we've discovered that AMD drivers for 18.2 aren't supported until AMD rewrites everything I guess? Didn't make sense to me, but that's what we read on the forums. Was unable to get 17.3 to boot at all, even with parameter changes.

  • Maybe it is related to your bios secure boot configuration? – Pablo Recalde Aug 17 '17 at 22:32
0

Most likely the live cd is using some fall back drivers or something similar. Whatever the reason, below will probably fix you right up.

After installing Mint boot into recovery and install the proprietary driver from the driver manager. Source: https://community.linuxmint.com/hardware/view/21443

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.