0

I have problem with playing sounds in more than one program. In example, I have enabled YouTube in FireFox or any game and when I'm trying to listen music in VLC Media Player, I'm getting this error:

Audio output failed: The audio device "sysdefault:CARD=PCH" could not be used: Device or resource busy.

I tried to use Pulseaudio, but the quality of audio was poor and there was no bass (or that was distorted).

My sound cards in /proc/asound/cards:

0 [HDMI ]: HDA-Intel - HDA Intel HDMI HDA Intel HDMI at 0xc3610000 irq 49

1 [PCH ]: HDA-Intel - HDA Intel PCH HDA Intel PCH at 0xc3614000 irq 48

I have latest version of ALSA, same with the rest of the programs. I tried to reinstall ALSA.

I do not know if it has any connection with the problem, but the .wav files in any player are distorted too (.mp3, YouTube music, sounds on games, etc are ok).

Thanks in advance for your help :)

  • If you install pavucontrol, which is part of pulseaudio, you have a GUI that shows the the signal levels and some other info that might give you an indication of the problem. – meuh Aug 18 '17 at 15:00
3

The given message seems to pretty succinctly summarize the issue. ALSA does nothing itself to mediate simultaneous hardware access between multiple applications, and that is actually one of the big reasons that PulseAudio exists at all.

You've got a couple of options to deal with this, and unfortunately PulseAudio is the only widely supported one (the other big one is JACK, but that's mostly only supported by high-end multimedia applications). If you look at the PulseAudio configuration, it's actually possible to get significantly better audio quality than the default settings (which favor performance over all other aspects). For more info on that, check man pulse-daemon.conf in a terminal, or alternatively look here for slightly more specific info.

  • OK, I edited pulse config and sound is now better, but I have still problem with distorted bass. I still don't know how to fix it – topkek Aug 17 '17 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.