0

I haven't updated KeyPass 2.x (I'm still on 2.32), so what could have broken this program on Linux Mint 18.1 x64?

It used to be that normal Ctrl+[letter] shortcuts like Ctrl+C to copy, Ctrl+U to open URL in browser, etc. worked fine on this system. Now none of them do. I have to right-click and use context menu options. This persists after a restart. Unfortunately I'm not sure what updated that might have broken this.

It seems the Ctrl part is just being ignored entirely: In any text box within KeyPass where I try to paste with Ctrl+V, it instead types the letter v into the box.

Aside from KeyPass, everywhere else in the system my Ctrl key works just fine for copy/paste/undo/select all/etc. The only exception is that I also recently experienced this in pgAdminIII, but restarting the program (or perhaps my whole computer--not sure which it was) fixed it, because the problem did not persist after that. KeyPass remains broken between cold boots.

What components are at play here? How can I diagnose such a problem?

KeePass 2.x seems to be based on Mono, but I don't have mono-complete installed--I installed from the repo mentioned at https://sourceforge.net/p/keepass/discussion/329220/thread/17d1bd26/#4a47/2783 (IIRC--it was months ago now, and it's been working since then until somewhat recently. But I did seem to have that repo already there when I tried to add it again just now, so unless it didn't work and I installed some other way without cleaning up the repo, that's the version I have. From the rest of that thread I gather that the version I have has whatever it needs from Mono already compiled in?)


For lack of other ideas, after all the above, I upgraded to KeePass 2.36. It still has this behaviour.

Also it doesn't matter if I use left or right Ctrl, or even both at the same time.

closed as off-topic by Jeff Schaller, Stephen Rauch, Archemar, sebasth, Kusalananda Oct 9 '17 at 8:47

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Stephen Rauch, Archemar, sebasth, Kusalananda
If this question can be reworded to fit the rules in the help center, please edit the question.

1

I just switched to KeePassXC 2.2.0 (oldstable) and it works fine in the above regard, and was able to open existing database files from KeePass2.

This doesn't really answer the question as to what caused the above, but it's a useful solution, at least.

Not the answer you're looking for? Browse other questions tagged or ask your own question.