Resolved: See "However" at the end of the question for details.

I've managed to hose my login to a Unix box. I don't have an easy way of contacting the administrator, so I'd like to resolve it myself ideally. I don't have root access (that would be too easy).

Per the title, I've managed to create a large file through an app spamming stdout, which I now can't remove. rm -f doesn't work, nor does cat /dev/null >| $file, nor truncate -s 0 $file. Errors are akin to the following, for everything I've tried.

tr08[~]$ cat /dev/null >| wordlist.txt
-bash: wordlist.txt: Disk quota exceeded

Output from quota is unhelpful:

tr08[~]$ quota -v
Disk quotas for user meand (uid 8650):
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
                       0       0       0               0       0       0

I'm at a loss on what to do next. Google only gave me truncate and cat \dev\null, so any advice or suggestion would be gratefully received.

Output requested in the comments:

tr08[~]$ uname -a
Linux tr08.ecs #1 SMP Tue Sep 21 11:11:58 BST 2010 x86_64 x86_64 x86_64 GNU/Linux
tr08[~]$ mount | grep /m08ad
tau:/uspac/mc10/m10mr on /auto/complb/m10mr type nfs (rw,nosuid,intr,sloppy,addr=

However: I'm not sure what happened, but when I logged in to get the details Gilles requested in the comments, I tried an rm, which worked just fine. quota -v is now producing no output, either. I've no idea whether this is due to some admin intervention or some other cunning trickery, but it all appears sorted now.

  • What unix variant is this? The filesystem looks like NFS, is this right? Do you know what the filesystem type is on the server, and what OS it's running? If you don't know how to answer these questions, please post the output of uname -a and mount | grep /m10mr. – Gilles 'SO- stop being evil' Nov 9 '10 at 0:27
  • @Gilles: I've added that output, but it's moot now anyway; rm suddenly started working. – me_and Nov 10 '10 at 10:56

I don't really know, why the commands you mentioned would fail, but you could try

> wordlist.txt

This tells the shell to truncate the file to 0 length without spawning another process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.