4

I need to connect additional monitors on my computer and I get Fresco Logic FL2000DX USB display adapters. This adapters works perfect on Windows but I need to use on my development machine based on Ubuntu 16.04.

I find this on git hub: https://github.com/fresco-fl2000/fl2000 and try to install it but installation fail.

2

You should use Ubuntu 14 LTS instead of 16 LTS

This information is from https://github.com/fresco-fl2000/fl2000

On which kernel versions does this driver work?

This driver is tested on Ubuntu 14 LTS as well as some Android platforms with kernel version 3.10.x. This driver source might not compile on newer kernels (eg. 4.0 or above) because of the fast-moving API changes in the mainstream kernel. You might need to adapt it for your own use.

  • 1
    That mean I need to downgrade my Ubuntu? – Ivijan Stefan Stipić Aug 17 '17 at 6:45
  • 1
    Is there a way to recode this driver to work on 16 LTS? – Ivijan Stefan Stipić Aug 17 '17 at 6:45
  • 1
    @IvijanStefanStipić To get the driver work on Ubuntu 16 you need to compile a custom kernel from kernel.org . The 3.10.107 kernel version should work as motioned – GAD3R Aug 17 '17 at 7:59
  • 1
    No need to downgrade, just install an older kernel and select it in grub when booting up – Dagelf Dec 22 '18 at 13:51
3

Telling the full story so all the keywords will be included in my response for future searchability:

I've been looking everywhere for a driver or chipset info for the unbranded "Mini HD USB 3.0 HDMI Adapter" for years. I finally dug though enough duck duck go results to find a page that claims it uses the Fresco logic USB display driver, which brought me here.

I was able to get the driver to work using Linux Mint 18.2 "Sonya" with linux-headers-4.13.0-45-generic, but the instructions on git hub were not perfect.

  1. Clone the repository git clone https://github.com/FrescoLogic/FL2000.git (If you don't have git installed you can install it with sudo apt install git )
  2. Navigate to src: cd FL2000/src/
  3. Run make (contrary to the instructions, you don't need to edit KERNEL_PATH as the bug was fixed)
  4. Insert the module sudo insmod fl2000.ko
  5. Change to sample cd ../sample/
  6. Run make (I got an error here, but was able to test the driver and see an image despite the error)
  7. Run sudo ./fltest 0

This crashed the first time I ran it but worked when I re-ran it a second time. Running it a 3rd time, it hangs my system.

Rebooting with the device plugged into the USB port seems to help. It will work at first launch. However, during shutdown my system is unable to disconnect from it's built in RAMDrive and will hang, ctrl-alt-del will move it a few steps further, but then it hangs again forcing me to do a hard shutdown.


I'm not sure if fixing the error when running make in the sample directory make: /opt/hi3798/arm-hisiv200-linux/bin/arm-hisiv200-linux-gnueabi-gcc: Command not found would make this any more stable.

I googled and came across this thread saying I "need to add head file <sys/ioctl.h>" -- I didn't know how to do that so I followed the recommendation in this thread mentioning I should install some gcc packages:

sudo apt-get install gcc-arm-none-eabi gcc-arm-linux-gnueabi

After installing, make progressed further, but I am now getting a make: /opt/hi3798/arm-hisiv200-linux/bin/arm-hisiv20/opt/hi3798/arm-hisiv200-linux/bin/arm-hisiv200-linux-gnueabi-gcc: Command not found error.

Installing ia32-libs hasn't helped.

  • 1
    This is not the full driver, so even though it is able to display static images, something else is needed for it to work with display managers etc: github.com/FrescoLogic/FL2000/issues/12 – prusswan Jul 6 '18 at 5:13
  • Just a heads up to KDE users, during my installing and uninstalling of drivers to get this proof of concept working I lost the ability to grab and resize windows. Apparently kwin got uninstalled somewhere along the way; sudo apt install kwin fixed it. – virtualxtc Jul 6 '18 at 6:32
  • 2
    BTW, one good way to identify USB devices is to look at the vendor and device id (via lsusb or dmesg) and then google in the form 1234:5678. Unbranded devices in particular often just keep the ids of the generic chips. – dirkt Jul 6 '18 at 6:41
  • Have you managed to solve this? – TripleS Dec 26 '18 at 17:33
  • @TripleS that depends on what you mean by 'solve' can I properly install the driver?: yes. Does it work well / is it bug free / does it provide video?: no. – virtualxtc Dec 28 '18 at 2:40

protected by Community Nov 5 '18 at 2:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.