3

So apparently Gnome has changed the default shortcut for Lock screen to Super+L. That's fine by me, but I want to disable it and replace it with something else.

So I open the Keyboard->Shortcuts->System settings, where it claims that Ctrl+Alt+L is bound to locking screen. But when I press Super+L, I still get locked.

I then reassigned Super+L to Typing->Switch to next source. But I still get locked out on Super+L! Why is this and what to I do about it?

1
  • 1
    After changing the shortcut, try logging out. I changed the short cut and them logged out of the current user. I looged back in and now Super+L is no longer locking my screen. I am using Ubuntu-Gnome 16.10
    – AJN
    Commented Aug 16, 2017 at 16:58

1 Answer 1

0

Eventhough there's only one shortcut/keybinding listed in Keyboard->Shortcuts->Systems there may actually be more than one. If changing it the usual way doesn't work (after rebooting), I'd try opening a terminal and typing dconf-editor which brings up a graphical interface with lots of "hidden" settings. The setting you're looking for is /org/gnome/settings-daemon/plugins/media-keys/screensaver which locks the screen and by default is mapped to <Super>l.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .