1

I am trying to configure the lightdm GTK greeter for a dual-monitor setup, where the secondary monitor is placed on left. I followed this part of a guide that suggests using the display-setup-script config option to run a single-line command and so I did:

xrandr --output DVI-D-0 --primary --mode 1920x1080 --pos 1920x0 --right-of HDMI-0 --output HDMI-0 --mode 1920x1080 --pos 0x0 --left-of DVI-D-0

But it seems to have no effect as I still have to scroll to the far left of the left monitor to reach my primary monitor that's on the right.

Some places even suggest to put a monitors.xml file inside /var/lib/lightdm/.config/ but that isn't working either. Is there something else I haven't tried yet?

I am on fedora 26 and using the Awesome WM DE.

  • 1
    I had similar issues and ultimately decided to simply turn off the second monitor during login: xrandr --output HDMI-0 --off --output DVI-D-0 --primary – StrongBad Aug 16 '17 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.