I am trying to install FreeRadius 3.0.16 in Debian 9 from my local repository.
However when trying to install it I got this error:
The following packages have unmet dependencies: freeradius : Depends: libssl1.0.0 (>= 1.0.1e-2+deb7u5) but it is not installable
The culprit is in the original source code at
# Add dependency on distribution specific version of openssl that fixes Heartbleed (CVE-2014-0160). ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes),yes) SUBSTVARS = -Vdist:Depends="libssl1.0.0 (>= 1.0.1f-1ubuntu2)" else SUBSTVARS = -Vdist:Depends="libssl1.0.0 (>= 1.0.1e-2+deb7u5)" endif
Putting it checking for Debian 9 is not the ideal situation, as it can be compiled for several Debian flavours...
So, short of checking for the Debian version, is there any alternative of defining the Depends for Debian both and as an alternative depending on
libssl1.1 (>= 1.1)?